Ruby interface to IEEE 1364-2005 Verilog VPI
Ruby C Verilog
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
bin Fix 'ArgumentError: "VpiHigh" is not a valid VPI property' Apr 17, 2010
doc
examples Fix counter_spec.rb tests to work with RSpec 1.2.0 and later Apr 17, 2010
ext Make ruby-vpi work from rubygems without needing to set RUBYLIB Apr 25, 2010
lib add release info Aug 2, 2008
LICENSE change project license to the ISC license Jan 19, 2009
README add short project description in README, for display on GitHub Sep 22, 2008
Rakefile Fix so that gem install doesn't fail if the gem is already installed Jul 14, 2010
TODO replace user manual & website generation system with Gerbil Jan 28, 2008
gem_extconf.rb fix the *make* program on MASC machine doesn't like an empty Makefile Jan 22, 2007

README

Ruby-VPI -- Ruby interface to IEEE 1364-2005 Verilog VPI
========================================================

Ruby VPI is a library that lets Ruby programs access the
entire IEEE 1364-2005 Verilog VPI interface supported by
major Verilog simulators today.  It also serves as
platform for unit testing, rapid prototyping, and
systems integration of Verilog modules through Ruby.

Please see the ./doc/guide.html file in your web browser 
or visit http://ruby-vpi.rubyforge.org for more information.