Skip to content
Browse files

upgrade to binman 3 for better bundler support

  • Loading branch information...
1 parent fe83683 commit 9f80b812f1733201e0cf29ccb7a47a8fcaa9ab29 @sunaku committed
Showing with 3 additions and 2 deletions.
  1. +1 −0 Rakefile
  2. +2 −2 testr.gemspec
View
1 Rakefile
@@ -1 +1,2 @@
require "bundler/gem_tasks"
+require "binman/rakefile"
View
4 testr.gemspec
@@ -1,7 +1,6 @@
# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
require "testr/version"
-require "binman/gemspec"
Gem::Specification.new do |s|
s.name = "testr"
@@ -12,7 +11,7 @@ Gem::Specification.new do |s|
s.summary = "Continuous testing tool for Ruby"
s.description = nil
- s.files = `git ls-files`.split("\n") + Dir['man/**/*']
+ s.files = `git ls-files`.split("\n") + Dir["man/**/*"]
s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
@@ -20,6 +19,7 @@ Gem::Specification.new do |s|
# specify any dependencies here; for example:
# s.add_development_dependency "rspec"
# s.add_runtime_dependency "rest-client"
+ s.add_runtime_dependency "binman", "~> 3"
s.add_runtime_dependency "json", ">= 1.6.1"
s.add_runtime_dependency "guard", ">= 0.8.4"
s.add_runtime_dependency "diff-lcs", ">= 1.1.2"

0 comments on commit 9f80b81

Please sign in to comment.
Something went wrong with that request. Please try again.