New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

rumai ipx problems #8

Closed
ghedamat opened this Issue Mar 10, 2010 · 14 comments

Comments

Projects
None yet
2 participants
@ghedamat
Contributor

ghedamat commented Mar 10, 2010

Not sure that I've to post here my issue but i'm going to try :)

Rumai::IXP is giving me some issues..
issues are present using your wmiirc git project and also using the irb-rumai console following your tutorial

for example at this point

irb:> curr_view.areas[2].unshift terms
Rumai::IXP::Error: bad value -- in reply to #<Rumai::IXP.................

I get the same kind of error when I try to change the layout (stacked, default, etc) with the appropriate keyboard binding...

I'm not really understanding what's going on here.. Maybe you can help me...

By the way, thanks for this great project! I'm a ruby-wmii lover and this seems great to me!

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Mar 11, 2010

Owner

Yes, this is the correct place to ask.

Those commands work correctly on my system, so I suspect something is different in your environment.

Which version of Ruby, Rumai, wmii are you using? You need at least:

Owner

sunaku commented Mar 11, 2010

Yes, this is the correct place to ask.

Those commands work correctly on my system, so I suspect something is different in your environment.

Which version of Ruby, Rumai, wmii are you using? You need at least:

@ghedamat

This comment has been minimized.

Show comment
Hide comment
@ghedamat

ghedamat Mar 17, 2010

Contributor

Thanks for your answer! I have been away for the past few days..
I'll try to verify my versions of those packages as soon as possible and i'll let you know!
thanks again!

Contributor

ghedamat commented Mar 17, 2010

Thanks for your answer! I have been away for the past few days..
I'll try to verify my versions of those packages as soon as possible and i'll let you know!
thanks again!

@ghedamat

This comment has been minimized.

Show comment
Hide comment
@ghedamat

ghedamat Mar 17, 2010

Contributor

ok, i've checked and to me it seems that i mat all of your dependencies with the version you specified of each library...

So I do not know what's going on here..

Contributor

ghedamat commented Mar 17, 2010

ok, i've checked and to me it seems that i mat all of your dependencies with the version you specified of each library...

So I do not know what's going on here..

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Mar 17, 2010

Owner

Would you mind making a screencast so that I can see exactly what's happening with the terms?

Owner

sunaku commented Mar 17, 2010

Would you mind making a screencast so that I can see exactly what's happening with the terms?

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Mar 24, 2010

Owner

Please try upgrading to Rumai 3.2.1 and see if the problem still occurs.

Owner

sunaku commented Mar 24, 2010

Please try upgrading to Rumai 3.2.1 and see if the problem still occurs.

@ghedamat

This comment has been minimized.

Show comment
Hide comment
@ghedamat

ghedamat Mar 24, 2010

Contributor

ok, i've upgraded to rumai 3.2.1, the problem is the same, but now i'm also getting install errors, like:
Unrecognized directive 'project' in lib/rumai/inochi.yaml
Unrecognized directive 'package' in lib/rumai/inochi.yaml
Unrecognized directive 'library' in lib/rumai/inochi.yaml
Unrecognized directive 'tagline' in lib/rumai/inochi.yaml
Unrecognized directive 'website' in lib/rumai/inochi.yaml
Unrecognized directive 'authors' in lib/rumai/inochi.yaml
Unrecognized directive 'authors' in lib/rumai/inochi.yaml
Unrecognized directive 'version' in lib/rumai/inochi.yaml
Unrecognized directive 'release' in lib/rumai/inochi.yaml
Unrecognized directive 'runtime' in lib/rumai/inochi.yaml
Unrecognized directive 'runtime' in lib/rumai/inochi.yaml
Unrecognized directive 'devtime' in lib/rumai/inochi.yaml
Unrecognized directive 'devtime' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_doc_target' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_doc_options' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_ann_logins' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_ann_raa_id' in lib/rumai/inochi.yaml
Unrecognized directive 'gem_spec_logic' in lib/rumai/inochi.yaml
Unrecognized directive 'gem_spec_logic' in lib/rumai/inochi.yaml
so i think is not your fault but mine, or better it's a problem with my gentoo...

I'm a bit busy these days but I'll try to install rumai and your wmiirc on another distro...

tnx for your help!

I'll let you know!

Contributor

ghedamat commented Mar 24, 2010

ok, i've upgraded to rumai 3.2.1, the problem is the same, but now i'm also getting install errors, like:
Unrecognized directive 'project' in lib/rumai/inochi.yaml
Unrecognized directive 'package' in lib/rumai/inochi.yaml
Unrecognized directive 'library' in lib/rumai/inochi.yaml
Unrecognized directive 'tagline' in lib/rumai/inochi.yaml
Unrecognized directive 'website' in lib/rumai/inochi.yaml
Unrecognized directive 'authors' in lib/rumai/inochi.yaml
Unrecognized directive 'authors' in lib/rumai/inochi.yaml
Unrecognized directive 'version' in lib/rumai/inochi.yaml
Unrecognized directive 'release' in lib/rumai/inochi.yaml
Unrecognized directive 'runtime' in lib/rumai/inochi.yaml
Unrecognized directive 'runtime' in lib/rumai/inochi.yaml
Unrecognized directive 'devtime' in lib/rumai/inochi.yaml
Unrecognized directive 'devtime' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_doc_target' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_doc_options' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_ann_logins' in lib/rumai/inochi.yaml
Unrecognized directive 'pub_ann_raa_id' in lib/rumai/inochi.yaml
Unrecognized directive 'gem_spec_logic' in lib/rumai/inochi.yaml
Unrecognized directive 'gem_spec_logic' in lib/rumai/inochi.yaml
so i think is not your fault but mine, or better it's a problem with my gentoo...

I'm a bit busy these days but I'll try to install rumai and your wmiirc on another distro...

tnx for your help!

I'll let you know!

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Mar 30, 2010

Owner

Thanks for your feedback. I have fixed the install errors locally and will release a new gem soon.

Owner

sunaku commented Mar 30, 2010

Thanks for your feedback. I have fixed the install errors locally and will release a new gem soon.

@ghedamat

This comment has been minimized.

Show comment
Hide comment
@ghedamat

ghedamat Mar 31, 2010

Contributor

Thanks you for your great job!
I'll wait the new release!

Contributor

ghedamat commented Mar 31, 2010

Thanks you for your great job!
I'll wait the new release!

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Apr 1, 2010

Owner

I have released a new 3.2.2 version:
http://www.ruby-forum.com/topic/207164

Owner

sunaku commented Apr 1, 2010

I have released a new 3.2.2 version:
http://www.ruby-forum.com/topic/207164

@ghedamat

This comment has been minimized.

Show comment
Hide comment
@ghedamat

ghedamat Apr 1, 2010

Contributor

tnx! installation now works perfectly

but I'm still having the same issues,

for example when i try to apply the stacked layout to a column
i get this error:
http://pastebin.com/a0H59qxb

but as previously said maybe it's just a problem of my gentoo...

this weekend i'll try to install rumai and your wmiirc into a debian...

as usual thanks for your help!

Contributor

ghedamat commented Apr 1, 2010

tnx! installation now works perfectly

but I'm still having the same issues,

for example when i try to apply the stacked layout to a column
i get this error:
http://pastebin.com/a0H59qxb

but as previously said maybe it's just a problem of my gentoo...

this weekend i'll try to install rumai and your wmiirc into a debian...

as usual thanks for your help!

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Apr 1, 2010

Owner

Thanks for posting the entire stack trace. It is strange that ~/.wmii-3.5/ is your wmii configuration directory: I suppose you are using wmii 3.6. Could you please try using a newer wmii release (or compile from wmii's hg repository)?

Owner

sunaku commented Apr 1, 2010

Thanks for posting the entire stack trace. It is strange that ~/.wmii-3.5/ is your wmii configuration directory: I suppose you are using wmii 3.6. Could you please try using a newer wmii release (or compile from wmii's hg repository)?

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Apr 11, 2010

Owner

Any update on this issue?

Owner

sunaku commented Apr 11, 2010

Any update on this issue?

@ghedamat

This comment has been minimized.

Show comment
Hide comment
@ghedamat

ghedamat Apr 11, 2010

Contributor

! sorry for the late answer, I was working these days and did not have the time to make other tests.

I've just tried to use this version of wmii
http://dl.suckless.org/wmii/wmii+ixp-3.9b1.tbz

and it seems to work perfecty with rumai!
( or at least changing the layout of a column seems to work :P)

thanks man!

Now i'll try to use it for a while and if I'll find other issues I'll let you know!

Thanks again for your helpl!

Contributor

ghedamat commented Apr 11, 2010

! sorry for the late answer, I was working these days and did not have the time to make other tests.

I've just tried to use this version of wmii
http://dl.suckless.org/wmii/wmii+ixp-3.9b1.tbz

and it seems to work perfecty with rumai!
( or at least changing the layout of a column seems to work :P)

thanks man!

Now i'll try to use it for a while and if I'll find other issues I'll let you know!

Thanks again for your helpl!

@sunaku

This comment has been minimized.

Show comment
Hide comment
@sunaku

sunaku Apr 11, 2010

Owner

Good, thanks for your feedback.

I have updated the documentation to say wmii 3.9 or newer is needed:

Closing this issue.

Owner

sunaku commented Apr 11, 2010

Good, thanks for your feedback.

I have updated the documentation to say wmii 3.9 or newer is needed:

Closing this issue.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment