Skip to content
This repository

Unmodified clone of the GRAMPS svn repository at https://gramps.svn.sourceforge.net/svnroot/gramps starting at r15000.

README
Please read the COPYING file first.
If building from source, also read the INSTALL file (at least through the
"SUPER-SHORT VERSION") before going further.

Requirements
--------------------------------
The following packages *MUST* be installed in order for Gramps to work:
   Python 2.7 or greater
   GTK 3.0 or greater
   pygobject 3.3.2 or greater
   librsvg2 (svg icon view)
   xdg-utils

The following package is needed for full translation of the interface
to your language:
   language-pack-gnome-xx 
                    Translation of GTK elements to your language, with             
                    xx your language code eg for Dutch you need
                    language-pack-gnome-nl. The translation of the
                    Gramps strings is included with the source code.


The following packages are *STRONGLY RECOMMENDED* to be installed:
   osmgpsmap        Used to show maps in the geography view. 
                    Without this the GeoView will not be active, see
                    http://gramps-project.org/wiki/index.php?title=Gramps_3.3_Wiki_Manual_-_Main_Window#Geography_Category
                    The package is named osmgpsmap, osm-gps-map
                    or python-osmgpsmap. Or obtain it from: http://nzjrs.github.com/osm-gps-map/
   GraphViz         Enable creation of graphs using GraphViz engine.
                    Without this no beautiful graphs can be created.
                    Obtain it from: http://www.graphviz.org
   pyexiv2          Enables Gramps to manage Exif metadata embedded in your
                    media. Gramps needs version 0.1.3 or greater.
                    Obtain it from: http://tilloy.net/dev/pyexiv2/download.html  

The following packages are optional
   gtkspell         Enable spell checking in the notes. Gtkspell depends on 
                    enchant. A version of gtkspell with gobject introspection
                    is needed (if not the official yet, use
                    https://github.com/manisandro/gtkspell3/tree/changes/gtkspell)

   ttf-freefont     More font support in the reports

   gir-webkit       GObject introspection data of WebKit is required for the
                    hidden view 'Htmlview', which allows websites to be opened in
                    Gramps. Users can unhide the view in the plugin manager. 
                    A html renderer must be installed to use the view.
                    !! PACKAGERS, Test if on your distribution
                    webkit and Gramps is stable. If you obtain crashes, patch 
                    src/plugins/view/htmlrenderer.py and
                    src/plugins/view/geoview.gpr.py, so as to remove:
                       from gi.repository import WebKit as webkit

   goocanvas2:
                    Required for the Graphview plugin

No longer needed in 4.0:
   pygoocanvas
No longer needed in 3.3:
   python-enchant Enchant
No longer needed in 3.2:
   python glade bindings
No longer needed in 3.1:
   yelp             Gnome help browser. At the moment no help is shipped

Documentation
---------------------------------
The User Manual is now maintained on the gramps website,
http://www.gramps-project.org/wiki/index.php?title=User_manual

--------------------------------
The Gramps Project
http://gramps-project.org
Something went wrong with that request. Please try again.