Installation: FreeBSD

Seth edited this page Jul 22, 2015 · 5 revisions
Clone this wiki locally

This page describes how to install sup on FreeBSD-10, though the same instructions should apply to 9.x.

Installing dependencies

In your /etc/make.conf (or /usr/local/etc/poudriere.d/<jailname>-make.conf if using poudriere), add the following lines to specify that we want to use Ruby 2.1:


Then either build and install the following ports (building directly with make -C /usr/ports/<dir/port> all install clean or with portmaster or poudriere...) or install the corresponding packages:


Installing sup

At this stage, it is best to allow gem to install sup's dependencies, as some of the versions in ports are slightly out of date. As root, run:

gem install ncursesw
gem install sup

Next step

See the New User Guide.