QWindow, QView background color alpha broken on 3.6beta? #606

Closed
iani opened this Issue Oct 18, 2012 · 2 comments

Comments

Projects
None yet
2 participants
@iani
Contributor

iani commented Oct 18, 2012

Hello,

Trying out 3.6beta, latest release, SuperColliderCocoa version, on MacOS
10.8.2:
Transparency (alpha < 1) does not work for Window:background, nor for its
top view.

// 1.
w = Window().front;
w.view.background = Color.red; // color works ok.
w.view.background = Color(0.1, 0.2, 0.3, 0.1); // Window becomes grey, not
semi-transparent.

// 2.
w = Window().front; // trying background alpha, with new window
w.background = Color(0.1, 0.2, 0.3, 0.01); // window stays gray, but should
be transparent.

I counter-checked this with 3.5.6 latest release, and it works fine there.

I am using GUI.qt on 3.5.6 with style set to CDE. Also tried with Macintosh
(aqua) and Plastique.

Iannis Zannos

@jleben

This comment has been minimized.

Show comment Hide comment
@jleben

jleben Dec 3, 2012

Owner

There has been a fix related to this: bd2d988
Is it still an issue, or can we close?

Owner

jleben commented Dec 3, 2012

There has been a fix related to this: bd2d988
Is it still an issue, or can we close?

@jleben

This comment has been minimized.

Show comment Hide comment
@jleben

jleben Dec 17, 2012

Owner

Closing, seems to be fixed.

Owner

jleben commented Dec 17, 2012

Closing, seems to be fixed.

@jleben jleben closed this Dec 17, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment