New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

slack-client dependency deprecated (use @slack/client) #398

Open
beevelop opened this Issue Jan 11, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@beevelop

beevelop commented Jan 11, 2018

Expected Behavior

No deprecation warning.

Current Behavior

npm WARN deprecated slack-client@1.5.1: Use @slack/client instead, this package is no longer maintained

Possible Solution

Use @slack/client instead of slack-client dependency.

Steps to Reproduce (for bugs)

npm i

Your Environment

  • Superscript version: 1.0.0
  • npm: 5.6.0
  • node: 9.3.0
@beevelop

This comment has been minimized.

Show comment
Hide comment
@beevelop

beevelop Jan 11, 2018

slack-client does also cause the following deprecation notice to appear on installation:

npm WARN deprecated coffee-script@1.9.3: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)

beevelop commented Jan 11, 2018

slack-client does also cause the following deprecation notice to appear on installation:

npm WARN deprecated coffee-script@1.9.3: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment