Permalink
Browse files

Add active_support for 1.9 compatibility. String in ruby 1.9 doesn't …

…respond to 'first'.
  • Loading branch information...
1 parent dd28f5b commit 5bf042efcb76bdccff553e304a19ca6d4c08c7e1 @krekoten krekoten committed with Sven Fuchs Sep 29, 2010
Showing with 5 additions and 1 deletion.
  1. +1 −0 lib/minimal.rb
  2. +4 −1 minimal.gemspec
View
@@ -1,4 +1,5 @@
require 'action_view'
+require 'active_support/core_ext/string/access'
module Minimal
autoload :Template, 'minimal/template'
View
@@ -17,7 +17,10 @@ Gem::Specification.new do |s|
s.rubyforge_project = '[none]'
s.required_rubygems_version = '>= 1.3.6'
- s.add_dependency 'actionpack', '>=3.0.0.beta2'
+ rails_frameworks_version = '>=3.0.0.beta2'
+
+ s.add_dependency 'actionpack', rails_frameworks_version
+ s.add_dependency 'activesupport', rails_frameworks_version
s.add_development_dependency 'test_declarative'
end

0 comments on commit 5bf042e

Please sign in to comment.