Skip to content
Newer
Older
100644 28 lines (24 sloc) 1.15 KB
9e20201 @lawrencepit Issue #116 Expose as a gem
lawrencepit authored
1 # encoding: utf-8
2
3 Gem::Specification.new do |s|
4 s.name = "rails-i18n"
03422d7 @kuroda Release the version 5.0.0.beta3
kuroda authored
5 s.version = '5.0.0.beta3'
9e20201 @lawrencepit Issue #116 Expose as a gem
lawrencepit authored
6 s.authors = ["Rails I18n Group"]
7 s.email = "rails-i18n@googlegroups.com"
8 s.homepage = "http://github.com/svenfuchs/rails-i18n"
4a8e1f5 @kuroda Update the summary and description of gemspec
kuroda authored
9 s.summary = "Common locale data and translations for Rails i18n."
10 s.description = "A set of common locale data and translations to internationalize and/or localize your Rails applications."
6acba7b @kuroda Specify MIT license on gemspec file
kuroda authored
11 s.license = 'MIT'
9e20201 @lawrencepit Issue #116 Expose as a gem
lawrencepit authored
12
392c65f @nashbridges Add pluralization rules for non-English-like locales
nashbridges authored
13 s.files = Dir.glob("lib/**/*") + Dir.glob("rails/locale/*") +
14 Dir.glob("rails/pluralization/*") + Dir.glob("rails/transliteration/*") +
29e55b6 @kuroda Bump version to 0.6.3
kuroda authored
15 %w(README.md CHANGELOG.md MIT-LICENSE.txt)
9e20201 @lawrencepit Issue #116 Expose as a gem
lawrencepit authored
16 s.platform = Gem::Platform::RUBY
17 s.require_path = 'lib'
18 s.rubyforge_project = '[none]'
19 s.required_rubygems_version = '>= 1.3.5'
20
eb8fc2d @digitalfrost Update dependancy to i18n
digitalfrost authored
21 s.add_runtime_dependency('i18n', '~> 0.7')
252113a @kuroda Get ready for the Rails 5.0 and RSpec 3
kuroda authored
22 s.add_runtime_dependency('railties', '~> 5.0.0.beta1')
42bf298 @kuroda Specify the version for rspec-rails on gemspec
kuroda authored
23 s.add_development_dependency "rspec-rails", "~> 3.1"
21d531b @kuroda Remove the causes deprecation warnings
kuroda authored
24 s.add_development_dependency "i18n-spec", "~> 0.6.0"
425bf17 @kuroda Update development dependencies.
kuroda authored
25 s.add_development_dependency "spork", "= 1.0.0rc3"
7f29395 @kuroda Bump i18n-tasks to 0.9.2
kuroda authored
26 s.add_development_dependency 'i18n-tasks', '~> 0.9.2'
9e20201 @lawrencepit Issue #116 Expose as a gem
lawrencepit authored
27 end
Something went wrong with that request. Please try again.