Skip to content
Adds the ability to import and map Java packages to nested Ruby modules/classes to RJB.
Ruby
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
lib
README.textile
rjb-require.gemspec

README.textile

Rjb.require

Adds the ability to import and map Java packages to nested Ruby modules/classes to RJB.

Usage

require 'rjb/require'

# java.net.URL is already in your classpath
Rjb.require 'java.net.URL'
Java::Net::URL.new('http://github.com')

# load some custom library
Rjb.load_from 'path/to/htmlunit' # loads all jar files to Rjb
Rjb.require 'com.gargoylesoftware.htmlunit.WebClient'

Authors

Something went wrong with that request. Please try again.