Permalink
Browse files

Don't test Rails 4.0 if RUBY_VERSION < 1.9.3

  • Loading branch information...
1 parent b5d91bd commit dcaf7a74951bb7d2cdada5564315ca25245f1bbd @kuroda kuroda committed Mar 30, 2013
Showing with 12 additions and 3 deletions.
  1. +4 −2 Appraisals
  2. +8 −1 Rakefile
View
@@ -15,6 +15,8 @@ appraise 'rails-3.2' do
gem 'rails', '~> 3.2.0.rc1'
end
-appraise 'rails-4.0' do
- gem 'rails', '~> 4.0.0.beta1'
+if RUBY_VERSION >= '1.9.3'
+ appraise 'rails-4.0' do
+ gem 'rails', '~> 4.0.0.beta1'
+ end
end
View
@@ -13,5 +13,12 @@ task :default => [:all]
desc 'Test the plugin under all supported Rails versions.'
task :all => ["appraisal:install"] do |t|
- exec('rake appraisal test')
+ if RUBY_VERSION < '1.9.3'
+ exec('rake appraisal:rails-2.3 test')
+ exec('rake appraisal:rails-3.0 test')
+ exec('rake appraisal:rails-3.1 test')
+ exec('rake appraisal:rails-3.2 test')
+ else
+ exec('rake appraisal test')
+ end
end

0 comments on commit dcaf7a7

Please sign in to comment.