Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Regenerate gemspec for version 1.1.0

  • Loading branch information...
commit fa9508faf661720c5523a124c7950855964af7b9 1 parent 1ecaa28
@ohadlevy ohadlevy authored ohadlevy committed
Showing with 21 additions and 15 deletions.
  1. +21 −15 safemode.gemspec
View
36 safemode.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = "safemode"
- s.version = "1.0.2"
+ s.version = "1.1.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Sven Fuchs", "Peter Cooper", "Matthias Viehweger", "Kingsley Hendrickse", "Ohad Levy"]
- s.date = "2012-10-24"
+ s.authors = ["Sven Fuchs", "Peter Cooper", "Matthias Viehweger", "Kingsley Hendrickse", "Ohad Levy", "Dmitri Dolguikh"]
+ s.date = "2012-12-10"
s.description = "A library for safe evaluation of Ruby code based on RubyParser and Ruby2Ruby. Provides Rails ActionView template handlers for ERB and Haml."
s.email = "ohadlevy@gmail.com"
s.extra_rdoc_files = [
@@ -49,42 +49,48 @@ Gem::Specification.new do |s|
s.homepage = "http://github.com/svenfuchs/safemode"
s.licenses = ["MIT"]
s.require_paths = ["lib"]
- s.rubygems_version = "1.8.19"
+ s.rubygems_version = "1.8.24"
s.summary = "A library for safe evaluation of Ruby code based on ParseTree/RubyParser and Ruby2Ruby"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<ruby2ruby>, [">= 2.0.0.b1"])
- s.add_runtime_dependency(%q<ruby_parser>, [">= 3.0.0.a9"])
+ s.add_runtime_dependency(%q<sexp_processor>, [">= 4.1.2"])
+ s.add_runtime_dependency(%q<ruby2ruby>, [">= 2.0.1"])
+ s.add_runtime_dependency(%q<ruby_parser>, [">= 3.0.1"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
+ s.add_development_dependency(%q<bundler>, ["~> 1.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.8.3"])
s.add_development_dependency(%q<rcov>, [">= 0"])
s.add_development_dependency(%q<simplecov>, [">= 0"])
+ s.add_development_dependency(%q<test-unit>, [">= 0"])
s.add_development_dependency(%q<rake>, [">= 0"])
else
- s.add_dependency(%q<ruby2ruby>, [">= 2.0.0.b1"])
- s.add_dependency(%q<ruby_parser>, [">= 3.0.0.a9"])
+ s.add_dependency(%q<sexp_processor>, [">= 4.1.2"])
+ s.add_dependency(%q<ruby2ruby>, [">= 2.0.1"])
+ s.add_dependency(%q<ruby_parser>, [">= 3.0.1"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
- s.add_dependency(%q<simplecov>, [">= 0"])
s.add_dependency(%q<rcov>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<test-unit>, [">= 0"])
s.add_dependency(%q<rake>, [">= 0"])
end
else
- s.add_dependency(%q<ruby2ruby>, [">= 2.0.0.b1"])
- s.add_dependency(%q<ruby_parser>, [">= 3.0.0.a9"])
+ s.add_dependency(%q<sexp_processor>, [">= 4.1.2"])
+ s.add_dependency(%q<ruby2ruby>, [">= 2.0.1"])
+ s.add_dependency(%q<ruby_parser>, [">= 3.0.1"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
- s.add_dependency(%q<simplecov>, [">= 0"])
s.add_dependency(%q<rcov>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<test-unit>, [">= 0"])
s.add_dependency(%q<rake>, [">= 0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.