Permalink
Browse files

remove jeweler, ignore gems

  • Loading branch information...
1 parent d40418e commit 66246d3bcba25df539b1da503609920103c06ea5 Sven Fuchs committed Apr 2, 2010
Showing with 23 additions and 24 deletions.
  1. +1 −1 .gitignore
  2. +0 −23 Rakefile
  3. +22 −0 steam.gemspec
View
@@ -1,2 +1,2 @@
vendor
-*.gemspec
+*.gem
View
@@ -1,23 +0,0 @@
-$: << File.expand_path('../lib', __FILE__)
-
-require 'rake/testtask'
-require 'steam/version'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |s|
- s.name = 'steam'
- s.version = Steam::VERSION
- s.summary = 'Headless integration testing w/ HtmlUnit: enables testing JavaScript-driven web sites '
- s.email = 'svenfuchs@artweb-design.de'
- s.homepage = 'http://github.com/svenfuchs/steam'
- s.description = 'Steam is a headless integration testing tool driving HtmlUnit to enable testing JavaScript-driven web sites.'
- s.authors = ['Sven Fuchs', 'Clemens Kofler']
- s.files = FileList['[A-Z]*', 'lib/steam.rb', 'lib/{core_ext,steam}/**/*']
-
- s.add_dependency 'rjb', '>= 1.2.0'
- s.add_dependency 'locator', '>= 0.0.6'
- end
-rescue LoadError
- puts 'Jeweler, or one of its dependencies, is not available. Install it with: sudo gem install technicalpickles-jeweler -s http://gems.github.com'
-end
View
@@ -0,0 +1,22 @@
+# encoding: utf-8
+
+require File.expand_path('../lib/steam/version', __FILE__)
+
+Gem::Specification.new do |s|
+ s.name = 'steam'
+ s.version = Steam::VERSION
+ s.authors = ['Sven Fuchs']
+ s.email = 'svenfuchs@artweb-design.de'
+ s.homepage = 'http://github.com/svenfuchs/steam'
+ s.summary = 'Headless integration testing w/ HtmlUnit: enables testing JavaScript-driven web sites'
+ s.description = 'Steam is a headless integration testing tool driving HtmlUnit to enable testing JavaScript-driven web sites.'
+ s.files = Dir.glob('lib/**/*') + %w(MIT-LICENSE README.textile)
+
+ s.add_runtime_dependency 'rjb', '>= 1.2.0'
+ s.add_runtime_dependency 'locator', '>= 0.0.6'
+
+ s.platform = Gem::Platform::RUBY
+ s.require_path = 'lib'
+ s.rubyforge_project = '[none]'
+ s.required_rubygems_version = '>= 1.3.6'
+end

0 comments on commit 66246d3

Please sign in to comment.