New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Liquid Exception: stack level too deep in site.json #14

Closed
ecler opened this Issue Dec 12, 2014 · 7 comments

Comments

2 participants
@ecler

ecler commented Dec 12, 2014

Hello, I'd love to use your theme, but as a Ruby noob, I can't fix a bug "Liquid Exception: stack level too deep in site.json" when I'm running "jekyll b". How can I fix this?

@swanson

This comment has been minimized.

Show comment
Hide comment
@swanson

swanson Dec 13, 2014

Owner

Sounds like some recursion issue - can you post steps to reproduce?

Owner

swanson commented Dec 13, 2014

Sounds like some recursion issue - can you post steps to reproduce?

@ecler

This comment has been minimized.

Show comment
Hide comment
@ecler

ecler Dec 13, 2014

Clone your repo, install jekyll, go to your theme folder and fire "jekyll build". If I delete site.json file, everything will work great. I use rbenv, Ruby 2.1.5 and Jekyll 2.5.2.
jekyll

ecler commented Dec 13, 2014

Clone your repo, install jekyll, go to your theme folder and fire "jekyll build". If I delete site.json file, everything will work great. I use rbenv, Ruby 2.1.5 and Jekyll 2.5.2.
jekyll

@swanson

This comment has been minimized.

Show comment
Hide comment
@swanson

swanson Dec 13, 2014

Owner
☁  lagom [master] ⚡ ruby -v
ruby 2.1.5p273 (2014-11-13 revision 48405) [x86_64-darwin13.0]
☁  lagom [master] ⚡ jekyll -v
Notice: for 10x faster LSI support, please install http://rb-gsl.rubyforge.org/
jekyll 2.2.0
☁  lagom [master] ⚡ jekyll build
Notice: for 10x faster LSI support, please install http://rb-gsl.rubyforge.org/
Configuration file: /Users/matt/dev/scratch/lagom/_config.yml
            Source: /Users/matt/dev/scratch/lagom
       Destination: /Users/matt/dev/scratch/lagom/_site
      Generating... 
                    done.

I built Ruby 2.1.5, ran rbenv local 2.1.5, then bundle install and everything worked fine. I'll try with a newer release of jekyll.

Owner

swanson commented Dec 13, 2014

☁  lagom [master] ⚡ ruby -v
ruby 2.1.5p273 (2014-11-13 revision 48405) [x86_64-darwin13.0]
☁  lagom [master] ⚡ jekyll -v
Notice: for 10x faster LSI support, please install http://rb-gsl.rubyforge.org/
jekyll 2.2.0
☁  lagom [master] ⚡ jekyll build
Notice: for 10x faster LSI support, please install http://rb-gsl.rubyforge.org/
Configuration file: /Users/matt/dev/scratch/lagom/_config.yml
            Source: /Users/matt/dev/scratch/lagom
       Destination: /Users/matt/dev/scratch/lagom/_site
      Generating... 
                    done.

I built Ruby 2.1.5, ran rbenv local 2.1.5, then bundle install and everything worked fine. I'll try with a newer release of jekyll.

@swanson

This comment has been minimized.

Show comment
Hide comment
@swanson

swanson Dec 13, 2014

Owner
☁  lagom [master] ⚡ ruby -v
ruby 2.1.5p273 (2014-11-13 revision 48405) [x86_64-darwin13.0]
☁  lagom [master] ⚡ jekyll -v
jekyll 2.4.0
☁  lagom [master] ⚡ jekyll build
Configuration file: /Users/matt/dev/scratch/lagom/_config.yml
            Source: /Users/matt/dev/scratch/lagom
       Destination: /Users/matt/dev/scratch/lagom/_site
      Generating... 
                    done.
 Auto-regeneration: disabled. Use --watch to enable.

Still good with jekyll-2.2.4 (the most up-to-date versions that GitHub Pages runs)

Owner

swanson commented Dec 13, 2014

☁  lagom [master] ⚡ ruby -v
ruby 2.1.5p273 (2014-11-13 revision 48405) [x86_64-darwin13.0]
☁  lagom [master] ⚡ jekyll -v
jekyll 2.4.0
☁  lagom [master] ⚡ jekyll build
Configuration file: /Users/matt/dev/scratch/lagom/_config.yml
            Source: /Users/matt/dev/scratch/lagom
       Destination: /Users/matt/dev/scratch/lagom/_site
      Generating... 
                    done.
 Auto-regeneration: disabled. Use --watch to enable.

Still good with jekyll-2.2.4 (the most up-to-date versions that GitHub Pages runs)

@swanson

This comment has been minimized.

Show comment
Hide comment
@swanson

swanson Dec 13, 2014

Owner

I can reproduce your error with jekyll-2.2.5

Owner

swanson commented Dec 13, 2014

I can reproduce your error with jekyll-2.2.5

@swanson

This comment has been minimized.

Show comment
Hide comment
@swanson

swanson Dec 13, 2014

Owner

Opened an issue: jekyll/jekyll#3207

Will continue trying to debug.

Owner

swanson commented Dec 13, 2014

Opened an issue: jekyll/jekyll#3207

Will continue trying to debug.

@swanson swanson closed this in 4a8a593 Dec 13, 2014

@swanson

This comment has been minimized.

Show comment
Hide comment
@swanson

swanson Dec 13, 2014

Owner

Think it should be resolved, do a git pull and see if that fixes it.

Owner

swanson commented Dec 13, 2014

Think it should be resolved, do a git pull and see if that fixes it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment