Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Fix configure for binary specified by --with-python3

  • Loading branch information...
commit a161e5ab4ef310d0639f10cf75a490b5106bfe0a 1 parent b170788
@wsfulton wsfulton authored
Showing with 14 additions and 8 deletions.
  1. +14 −8 configure.ac
View
22 configure.ac
@@ -707,15 +707,21 @@ AS_HELP_STRING([--with-python3=path], [Set location of Python 3.x executable]),[
if test x"${PY3BIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Python 3.x support])
else
- for py_ver in 3 3.6 3.5 3.4 3.3 3.2 3.1 3.0; do
- AC_CHECK_PROGS(PYTHON3, [python$py_ver])
- if test -n "$PYTHON3"; then
- AC_CHECK_PROGS(PY3CONFIG, [$PYTHON3-config])
- if test -n "$PY3CONFIG"; then
- break
+ if test "x$PY3BIN" = xyes; then
+ for py_ver in 3 3.6 3.5 3.4 3.3 3.2 3.1 3.0; do
+ AC_CHECK_PROGS(PYTHON3, [python$py_ver])
+ if test -n "$PYTHON3"; then
+ AC_CHECK_PROGS(PY3CONFIG, [$PYTHON3-config])
+ if test -n "$PY3CONFIG"; then
+ break
+ fi
fi
- fi
- done
+ done
+ else
+ PYTHON3="$PY3BIN"
+ AC_CHECK_PROGS(PY3CONFIG, [$PYTHON3-config])
+ fi
+
if test -n "$PYTHON3" -a -n "$PY3CONFIG"; then
AC_MSG_CHECKING([for Python 3.x prefix])
Please sign in to comment.
Something went wrong with that request. Please try again.