New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ssh connection struggling #1945

Closed
dab opened this Issue Jun 11, 2015 · 8 comments

Comments

Projects
None yet
5 participants
@dab

dab commented Jun 11, 2015

Trying to discover emacs area. Usually I'm working on my remote server over ssh. With vim I easy can connect with or without plugins, like :VimFiler ssh://host. Tried to do thing like this in spacemacs with no success.

Used C-x C-f /:ssh:host: — got Waiting for remote prompts message and then timeout error. Also tried SPC-f-f/:ssh:host with same result. At the same time I can use ssh in vim, so the problem is not the network itself.

How I can make the ssh with spacemacs working?

Thanks.

@cpaulik

This comment has been minimized.

Contributor

cpaulik commented Jun 11, 2015

The correct syntax should be SPC-f-f /ssh:host:/path/to/file

See the quickstart guide for the various syntax possibilities.

I've got the host in my .ssh/config file and helm offers autocompletion for the hosts.

@dab

This comment has been minimized.

dab commented Jun 11, 2015

@cpaulik thanks! tried this combination already, but it's hanging on and does not respond to keys except C-g. Reading troubleshooting guide now.

@syl20bnr

This comment has been minimized.

Owner

syl20bnr commented Jun 11, 2015

Do you use any special shell on the remote host ?

@dab

This comment has been minimized.

dab commented Jun 11, 2015

@syl20bnr using zsh there, tried to add lines from tramp troubleshooting guide to .zshrc with no success yet.

@dab

This comment has been minimized.

dab commented Jun 14, 2015

@syl20bnr removed prompt on remote host and this fixed connection timeout issue. Thanks for your support.

@dab dab closed this Jun 14, 2015

@puffnfresh

This comment has been minimized.

puffnfresh commented Dec 6, 2015

I have this problem - I do not want to remove prompt from the remote host. What can we do to fix this?

@puffnfresh

This comment has been minimized.

puffnfresh commented Dec 6, 2015

I've read the Emacs wiki and copied a solution from http://www.emacswiki.org/emacs/TrampMode#toc6

[[ $TERM == "dumb" ]] && unsetopt zle && PS1='$ '
@tfiala

This comment has been minimized.

Contributor

tfiala commented Sep 6, 2016

@puffnfresh This one worked better for me on my end, adding it to the top of the .zshrc file:

[[ $TERM == "dumb" ]] && unsetopt zle && PS1='$ ' && return

I was still hitting a problem with my oh-my-zsh setup using just the first option.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment