Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Unnecessary requirements for Doctrine #184

Closed
nogo opened this Issue · 4 comments

3 participants

@nogo

Does the AsseticBundle really need Doctrine? Which is included in this requirement ["symfony/framework-bundle": "~2.1"]

@kriswallsmith
Collaborator

Are you using AsseticBundle without FrameworkBundle?

@nogo

I try to create an app to display only the frontend, so there is no need for Doctrine. What I need are assets and twig.
But I see that the code is using ContainerAwareCommand from the FrameworkBundle.

@stof
Collaborator

This bundle is indeed relying on FrameworkBundle (not only the base command btw). Btw, FrameworkBundle only depends on Doctrine Common (for the annotations), not on the Doctrine ORM.

And if you are not using the FrameworkBundle, I would suggest you to use Assetic standalone instead of using AsseticBundle, which is meant to integrate Assetic in the fullstack framework.

@nogo

This is a good advice. I will test it with my app. Thanks

@nogo nogo closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.