Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 55 lines (54 sloc) 1.777 kB
8b3eaf2 @igorw [composer] add composer.json
igorw authored
1 {
2 "name": "symfony/validator",
3 "type": "library",
4 "description": "Symfony Validator Component",
5 "keywords": [],
105e8c3 @xabbuh link to https://symfony.com where possible
xabbuh authored
6 "homepage": "https://symfony.com",
8b3eaf2 @igorw [composer] add composer.json
igorw authored
7 "license": "MIT",
8 "authors": [
9 {
10 "name": "Fabien Potencier",
11 "email": "fabien@symfony.com"
12 },
13 {
14 "name": "Symfony Community",
105e8c3 @xabbuh link to https://symfony.com where possible
xabbuh authored
15 "homepage": "https://symfony.com/contributors"
8b3eaf2 @igorw [composer] add composer.json
igorw authored
16 }
17 ],
18 "require": {
53f3e05 @nicolas-grekas [3.0] Update required PHP to 5.5.9
nicolas-grekas authored
19 "php": ">=5.5.9",
b6804a1 @fabpot bumped deps on 2.8 in all composer.json
fabpot authored
20 "symfony/translation": "~2.8|~3.0"
8b3eaf2 @igorw [composer] add composer.json
igorw authored
21 },
8b4f04a @willdurand [Components] Tests/Autoloading fixes
willdurand authored
22 "require-dev": {
b6804a1 @fabpot bumped deps on 2.8 in all composer.json
fabpot authored
23 "symfony/phpunit-bridge": "~2.8|~3.0",
24 "symfony/http-foundation": "~2.8|~3.0",
25 "symfony/intl": "~2.8|~3.0",
26 "symfony/yaml": "~2.8|~3.0",
27 "symfony/config": "~2.8|~3.0",
28 "symfony/property-access": "~2.8|~3.0",
29 "symfony/expression-language": "~2.8|~3.0",
9de2b7a @Tobion adjust doctrine dependencies
Tobion authored
30 "doctrine/annotations": "~1.0",
66d8f0e @egulias #1581 - Strict in Email constraint and use of Egulias\EmailValidator
egulias authored
31 "doctrine/cache": "~1.0",
f1e6985 @nicolas-grekas Test lowest versions of dependencies
nicolas-grekas authored
32 "egulias/email-validator": "~1.2,>=1.2.1"
8b4f04a @willdurand [Components] Tests/Autoloading fixes
willdurand authored
33 },
8b3eaf2 @igorw [composer] add composer.json
igorw authored
34 "suggest": {
9de2b7a @Tobion adjust doctrine dependencies
Tobion authored
35 "doctrine/annotations": "For using the annotation mapping. You will also need doctrine/cache.",
45c0e5b @florianv [Validator] Added Doctrine cache
florianv authored
36 "doctrine/cache": "For using the default cached annotation reader and metadata cache.",
4713a6c @fabpot removed versions in composer.json files
fabpot authored
37 "symfony/http-foundation": "",
38 "symfony/intl": "",
39 "symfony/yaml": "",
66d8f0e @egulias #1581 - Strict in Email constraint and use of Egulias\EmailValidator
egulias authored
40 "symfony/config": "",
e4e9390 @fabpot fixed typo in composer.json
fabpot authored
41 "egulias/email-validator": "Strict (RFC compliant) email validation",
f03d97e @csarrazi [Validator] Updated outdated dependencies.
csarrazi authored
42 "symfony/property-access": "For using the 2.4 Validator API",
43 "symfony/expression-language": "For using the 2.4 Expression validator"
a2ab4f6 @fabpot updated composer.json files to contain information about autoloading …
fabpot authored
44 },
45 "autoload": {
4998c0a @Tobion Use PSR-4 everywhere instead of PSR-0
Tobion authored
46 "psr-4": { "Symfony\\Component\\Validator\\": "" }
a2ab4f6 @fabpot updated composer.json files to contain information about autoloading …
fabpot authored
47 },
eac6954 @willdurand Add minimum-stability (dev) in each component
willdurand authored
48 "minimum-stability": "dev",
7c82822 @Seldaek Add branch-alias for composer
Seldaek authored
49 "extra": {
50 "branch-alias": {
4799343 @fabpot updated version to 3.0
fabpot authored
51 "dev-master": "3.0-dev"
7c82822 @Seldaek Add branch-alias for composer
Seldaek authored
52 }
53 }
8b3eaf2 @igorw [composer] add composer.json
igorw authored
54 }
Something went wrong with that request. Please try again.