Permalink
Browse files

made deprecation notices less verbose

  • Loading branch information...
fabpot committed Feb 19, 2018
1 parent 81f82bf commit 6640451b63b5824395be75453dd9087f1f704581
Showing with 5 additions and 5 deletions.
  1. +1 −1 CHANGELOG.md
  2. +1 −1 DependencyInjection/MainConfiguration.php
  3. +1 −1 Resources/config/security.xml
  4. +2 −2 SecurityUserValueResolver.php
View
@@ -4,7 +4,7 @@ CHANGELOG
4.1.0
-----
- * The `logout_on_user_change` firewall option is deprecated and will be removed in 5.0.
+ * The `logout_on_user_change` firewall option is deprecated.
* deprecated `SecurityUserValueResolver`, use
`Symfony\Component\Security\Http\Controller\UserValueResolver` instead.
@@ -200,7 +200,7 @@ private function addFirewallsSection(ArrayNodeDefinition $rootNode, array $facto
->booleanNode('logout_on_user_change')
->defaultTrue()
->info('When true, it will trigger a logout for the user if something has changed. Note: No-Op option since 4.0. Will always be true.')
- ->setDeprecated('The "%path%.%node%" configuration key has been deprecated in Symfony 4.1 and will be removed in 5.0.')
+ ->setDeprecated('The "%path%.%node%" configuration key has been deprecated in Symfony 4.1.')
->end()
->arrayNode('logout')
->treatTrueLike(array())
@@ -165,7 +165,7 @@
<!-- Provisioning -->
<service id="security.user.provider.in_memory" class="Symfony\Component\Security\Core\User\InMemoryUserProvider" abstract="true" />
<service id="security.user.provider.in_memory.user" class="Symfony\Component\Security\Core\User\User" abstract="true">
- <deprecated>The "%service_id%" service is deprecated since Symfony 4.1 and will be removed in 5.0.</deprecated>
+ <deprecated>The "%service_id%" service is deprecated since Symfony 4.1.</deprecated>
</service>
<service id="security.user.provider.ldap" class="Symfony\Component\Security\Core\User\LdapUserProvider" abstract="true">
@@ -19,14 +19,14 @@
use Symfony\Component\Security\Core\User\UserInterface;
use Symfony\Component\Security\Http\Controller\UserValueResolver;
-@trigger_error(sprintf('The "%s" class is deprecated since Symfony 4.1 and will be removed in 5.0, use "%s" instead.', SecurityUserValueResolver::class, UserValueResolver::class), E_USER_DEPRECATED);
+@trigger_error(sprintf('The "%s" class is deprecated since Symfony 4.1, use "%s" instead.', SecurityUserValueResolver::class, UserValueResolver::class), E_USER_DEPRECATED);
/**
* Supports the argument type of {@see UserInterface}.
*
* @author Iltar van der Berg <kjarli@gmail.com>
*
- * @deprecated since Symfony 4.1, to be removed in 5.0. Use {@link UserValueResolver} instead
+ * @deprecated since Symfony 4.1, use {@link UserValueResolver} instead
*/
final class SecurityUserValueResolver implements ArgumentValueResolverInterface
{

0 comments on commit 6640451

Please sign in to comment.