Skip to content
Permalink
Browse files

bug #31456 Remove deprecated usage of some Twig features (fabpot)

This PR was merged into the 4.2 branch.

Discussion
----------

Remove deprecated usage of some Twig features

| Q             | A
| ------------- | ---
| Branch?       | 4.2
| Bug fix?      | yes
| New feature?  | no <!-- please update src/**/CHANGELOG.md files -->
| BC breaks?    | no     <!-- see https://symfony.com/bc -->
| Deprecations? | no <!-- please update UPGRADE-*.md and src/**/CHANGELOG.md files -->
| Tests pass?   | yes    <!-- please add some, will be required by reviewers -->
| Fixed tickets | n/a
| License       | MIT
| Doc PR        | n/a

<!--
Replace this notice by a short README for your feature/bugfix. This will help people
understand your PR and can be used as a start for the documentation.

Additionally (see https://symfony.com/roadmap):
 - Bug fixes must be submitted against the lowest maintained branch where they apply
   (lowest branches are regularly merged to upper ones so they get the fixes too).
 - Features and deprecations must be submitted against the master branch.
-->

Commits
-------

74afcd6 removed deprecated usage of some Twig features
  • Loading branch information...
fabpot committed May 10, 2019
2 parents 3fcec72 + 74afcd6 commit 7ca637ed0e73f8d58db379c7584e35520cab2be5
@@ -22,7 +22,7 @@
"doctrine/event-manager": "~1.0",
"doctrine/persistence": "~1.0",
"fig/link-util": "^1.0",
"twig/twig": "^1.40|^2.9",
"twig/twig": "^1.41|^2.10",
"psr/cache": "~1.0",
"psr/container": "^1.0",
"psr/link": "^1.0",
@@ -399,7 +399,7 @@
{# Support #}

{%- block form_rows -%}
{% for child in form if not child.rendered %}
{% for child in form|filter(child => not child.rendered) %}
{{- form_row(child) -}}
{% endfor %}
{%- endblock form_rows -%}
@@ -18,7 +18,7 @@
"require": {
"php": "^7.1.3",
"symfony/contracts": "^1.0.2",
"twig/twig": "^1.40|^2.9"
"twig/twig": "^1.41|^2.10"
},
"require-dev": {
"symfony/asset": "~3.4|~4.0",
@@ -22,7 +22,7 @@
"symfony/http-foundation": "~4.1",
"symfony/http-kernel": "~4.1",
"symfony/polyfill-ctype": "~1.8",
"twig/twig": "~1.40|~2.9"
"twig/twig": "~1.41|~2.10"
},
"require-dev": {
"symfony/asset": "~3.4|~4.0",
@@ -259,7 +259,7 @@

<h4>Defined as regular env variables</h4>
{% set requestserver = [] %}
{% for key, value in collector.requestserver if key not in collector.dotenvvars.keys %}
{% for key, value in collector.requestserver|filter((_, key) => key not in collector.dotenvvars.keys) %}
{% set requestserver = requestserver|merge({(key): value}) %}
{% endfor %}
{{ include('@WebProfiler/Profiler/table.html.twig', { data: requestserver }, with_context = false) }}
@@ -22,7 +22,7 @@
"symfony/routing": "~3.4|~4.0",
"symfony/twig-bundle": "~4.2",
"symfony/var-dumper": "~3.4|~4.0",
"twig/twig": "~1.34|~2.4"
"twig/twig": "^1.41|^2.10"
},
"require-dev": {
"symfony/console": "~3.4|~4.0",

0 comments on commit 7ca637e

Please sign in to comment.
You can’t perform that action at this time.