Skip to content
Permalink
Browse files

Improve Dotenv messages

  • Loading branch information...
xuanquynh committed Apr 11, 2019
1 parent e0c4528 commit e871a6a83a03caf9b357e4c8a5b7a989e2dd459f
Showing with 5 additions and 5 deletions.
  1. +3 −3 UPGRADE-4.3.md
  2. +1 −1 src/Symfony/Component/Dotenv/Dotenv.php
  3. +1 −1 src/Symfony/Component/Dotenv/Tests/DotenvTest.php
@@ -48,8 +48,8 @@ Doctrine Bridge
Dotenv
------

* First parameter of `Dotenv::__construct()` will change from `true` to `false` in Symfony 5.0. A deprecation warning
is triggered if no parameter is used. Use `$usePutenv = true` to upgrade without breaking changes.
* First parameter of `Dotenv::__construct()` will be changed from `true` to `false` in Symfony 5.0. A deprecation warning
is triggered if no parameter is provided. Use `$usePutenv = true` to upgrade without breaking changes.

EventDispatcher
---------------
@@ -170,7 +170,7 @@ SecurityBundle
TwigBridge
----------

* deprecated the `$requestStack` and `$requestContext` arguments of the
* deprecated the `$requestStack` and `$requestContext` arguments of the
`HttpFoundationExtension`, pass a `Symfony\Component\HttpFoundation\UrlHelper`
instance as the only argument instead

@@ -45,7 +45,7 @@ final class Dotenv
public function __construct(bool $usePutenv = true)
{
if (!\func_num_args()) {
@trigger_error(sprintf('The default value of "$usePutenv" argument of "%s\'s constructor will change from "true" to "false" in Symfony 5.0, you should define its value explicitly.', __METHOD__), E_USER_DEPRECATED);
@trigger_error(sprintf('The default value of "$usePutenv" argument of "%s" will be changed from "true" to "false" in Symfony 5.0. You should define its value explicitly.', __METHOD__), E_USER_DEPRECATED);
}
$this->usePutenv = $usePutenv;
@@ -417,7 +417,7 @@ public function testOverridingEnvVarsWithNamesMemorizedInSpecialVar()
/**
* @group legacy
* @expectedDeprecation The default value of "$usePutenv" argument of "%s's constructor will change from "true" to "false" in Symfony 5.0, you should define its value explicitly.
* @expectedDeprecation The default value of "$usePutenv" argument of "%s" will be changed from "true" to "false" in Symfony 5.0. You should define its value explicitly.
*/
public function testDeprecationWarning()
{

0 comments on commit e871a6a

Please sign in to comment.
You can’t perform that action at this time.