Skip to content
This repository

Jan 05, 2013

  1. Joseph Bielawski

    Restrict Monolog version to be in version `<1.3`.

    Because of conflict between `HttpKernel/Log/LoggerInterface` and `Psr\Log\LoggerInterface` (PSR-3)
    stloyd authored

Dec 06, 2012

  1. Martin Hasoň

    Removed useless branch alias for dev-master in composer.json

    hason authored

Oct 14, 2012

  1. Igor Wiedler

    Change monolog require-dev to use the branch alias instead of dev-master

    igorw authored

Sep 10, 2012

  1. Fabien Potencier

    reintroduced self.version for the replace entry

    fabpot authored
  2. Fabien Potencier

    replaced self.version by 2.1.* in composer.json files

    fabpot authored

Jul 31, 2012

  1. Victor Berchet

    [Composer] Bumped doctrine/orm to 2.2.3

    vicb authored

Jul 22, 2012

  1. Bernhard Schussek

    [Form] Improved FormRenderer API to reduce the size of the function c…

    …all stack during rendering
    webmozart authored

Jul 15, 2012

  1. Fabien Potencier

    Revert "raised the minimum version of PHP to 5.3.4 (closes #3856)"

    This reverts commit 2dcc448.
    fabpot authored

Jul 13, 2012

  1. Fabien Potencier

    raised the minimum version of PHP to 5.3.4 (closes #3856)

    We've raised the minimum version of PHP because of a PHP
    bug before 5.3.4:
    
    https://bugs.php.net/bug.php?id=52083
    https://bugs.php.net/bug.php?id=50027
    fabpot authored

Jul 04, 2012

  1. Christophe Coevoet

    Changed the minimum stability to dev for the testsuite

    stof authored

Jun 20, 2012

  1. Fabien Potencier

    merged 2.0

    fabpot authored

Jun 19, 2012

  1. Christophe Coevoet

    Added a missing provide for the swiftmailer bridge

    stof authored

May 20, 2012

  1. Christophe Coevoet

    Added missing dependency to doctrine common in the global composer.json

    Doctrine Common is a dependency of FrameworkBundle for the annotation
    reader.
    stof authored

May 17, 2012

  1. Christophe Coevoet

    Fixed the composer constraint for Doctrine Common

    stof authored

May 14, 2012

  1. Bernhard Schussek

    [OptionsParser] Renamed OptionsParser to OptionsResolver

    webmozart authored
  2. Bernhard Schussek

    [Form] Moved Options classes to new OptionsParser component

    webmozart authored

May 08, 2012

  1. Fabien Potencier

    raised the minimum version of Twig to 1.7

    fabpot authored

May 07, 2012

  1. Fabien Potencier

    updated minimum PHP version to 5.3.3

    5.3.3 has some interesting fixes and this is the version used by
    Redhat 6 and Debian 6
    fabpot authored

Apr 27, 2012

  1. Fabien Potencier

    Revert "merged branch Seldaek/master (PR #4133)"

    This reverts commit 00e7a94, reversing
    changes made to a01dec0.
    fabpot authored
  2. Jordi Boggiano

    Update branch aliases

    Seldaek authored

Apr 25, 2012

  1. Fabien Potencier

    merged 2.0

    fabpot authored
  2. Jordi Boggiano

    Bump monolog version

    Seldaek authored

Apr 18, 2012

  1. Michał Pipa

    Added Monolog to composer.json as dev dependency

    michal-pipa authored
  2. Fabien Potencier

    tweaked previous merge

    fabpot authored
  3. Fabien Potencier

    merged branch canni/composer (PR #3291)

    Commits
    -------
    
    aa055df [Composer] Stwitch to composer vendors management
    
    Discussion
    ----------
    
    [Composer] Stwitch to composer vendors management
    
    Bug fix: no
    Feature addition: yes
    Backwards compatibility break: No?
    Symfony2 tests pass: yes
    Fixes the following tickets: -
    Todo: -
    
    [![Build Status](https://secure.travis-ci.org/canni/symfony.png?branch=composer)](http://travis-ci.org/canni/symfony)
    
    This speeds up Travis CI builds to `~2 min` also makes vendor management
    a lot easier.
    
    ---------------------------------------------------------------------------
    
    by fabpot at 2012-02-09T06:24:24Z
    
    I'm -1 on this change. The `vendors.php` script is *only* for people working on the core so that we can run the unit tests. So, we need the flexibility to test on many different versions of the code and having the repository here is kind of mandatory.
    
    ---------------------------------------------------------------------------
    
    by Seldaek at 2012-02-09T08:15:28Z
    
    You can `composer install --dev` to get proper clones. I'm not really pro or against, just saying it's an option.
    
    ---------------------------------------------------------------------------
    
    by canni at 2012-02-09T08:28:54Z
    
    @fabpot I understand yours point, but from my view transferring the whole git structure of *vendors* is little pointless IMO (especially in Travis env)
    but I think I can make this change optional, so Travis and anyone that prefer to, can use `composer` an with old functionality available.
    
    (There will be almost no duplication, as anyway we're updating `composer.json`)
    
    ---------------------------------------------------------------------------
    
    by canni at 2012-02-09T09:20:17Z
    
    @fabpot I've enabled both behaviors, everything will work regardless of using `composer` or `vendors.php` this lets the developer decide what to use
    
    ---------------------------------------------------------------------------
    
    by drak at 2012-02-16T12:05:28Z
    
    Since there is a `--dev` option in Composer then I think this is a good idea.  You could also add composer.phar to the repo bin  directory.
    
    ---------------------------------------------------------------------------
    
    by henrikbjorn at 2012-02-16T12:06:55Z
    
    `--dev` have been renamed to `--prefer-source`
    
    ---------------------------------------------------------------------------
    
    by canni at 2012-02-16T12:22:01Z
    
    @fabpot any chance to consider this merge? If not, this PR can be closed.
    
    ---------------------------------------------------------------------------
    
    by henrikbjorn at 2012-02-16T12:25:51Z
    
    @canni This is the goal eventually. But i think we need composer to be a bit more stable in its solver.
    
    ---------------------------------------------------------------------------
    
    by francoispluchino at 2012-02-16T12:39:24Z
    
    :+1:
    
    ---------------------------------------------------------------------------
    
    by jmikola at 2012-04-06T18:19:27Z
    
    @fabpot: Is this PR still off the table, or are you reconsidering it with the `--prefer-source` option? I was just running symfony unit tests, and attempted to install deps with composer as I thought this PR or another like it had recently been merged to core. It wasn't :)
    
    Admittedly, it's a downside that vendor libs, even if git repositories, will be nestled within the `.composer/` directory.
    
    ---------------------------------------------------------------------------
    
    by drak at 2012-04-07T00:20:33Z
    
    @canni This PR needs to be rebased and reviewed because of the changed tests directory (there is no longer a central `tests/` folder).
    
    ---------------------------------------------------------------------------
    
    by canni at 2012-04-07T06:34:28Z
    
    Hey,
    
    will do after a weekend.
    
    canni
    
    Użytkownik Drak <reply@reply.github.com> napisał:
    
    >@canni This PR needs to be rebased and reviewed because of the changed tests directory (there is no longer a central `tests/` folder).
    >
    >---
    >Reply to this email directly or view it on GitHub:
    >#3291 (comment)
    
    ---------------------------------------------------------------------------
    
    by canni at 2012-04-08T19:02:03Z
    
    @drak done.
    fabpot authored

Apr 15, 2012

  1. William Durand

    Added propel1-bridge to the main composer.json

    willdurand authored

Apr 08, 2012

  1. Dariusz Górecki

    [Composer] Stwitch to composer vendors management

    Bug fix: no
    Feature addition: yes
    Backwards compatibility break: ?
    Symfony2 tests pass: yes
    Fixes the following tickets: -
    Todo: -
    
    This speeds up Travis CI builds to `~2 min` also makes vendor management
    a lot easier.
    canni authored

Mar 15, 2012

  1. Miha Vrhovnik

    fixed typos in composer file

    mvrhov authored

Feb 27, 2012

  1. Jordi Boggiano

    Removed version field

    Seldaek authored

Feb 25, 2012

  1. Jordi Boggiano

    Add branch-alias for composer

    Seldaek authored

Feb 22, 2012

  1. Drak

    Update composer for HttpFoundation's PHP 5.4 forward compatibility.

    drak authored

Feb 11, 2012

  1. Jeremy Mikola

    [DoctrineBridge] Suggest doctrine/data-fixtures dependency

    jmikola authored

Feb 09, 2012

  1. Fabien Potencier

    [MonologBundle] moved bundle to its own repository

    fabpot authored
  2. Henrik Bjørnskov

    Removed invalid dependencies and replaces in composer.json

    henrikbjorn authored

Jan 08, 2012

  1. Fabien Potencier

    Revert "merged 2.0"

    This reverts commit 7000e94, reversing
    changes made to 9d9013d.
    fabpot authored
Something went wrong with that request. Please try again.