Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

User Deprecated: Doctrine\Common\ClassLoader is deprecated. #28119

Closed
OtezVikentiy opened this issue Aug 2, 2018 · 9 comments
Closed

User Deprecated: Doctrine\Common\ClassLoader is deprecated. #28119

OtezVikentiy opened this issue Aug 2, 2018 · 9 comments

Comments

@OtezVikentiy
Copy link

@OtezVikentiy OtezVikentiy commented Aug 2, 2018

Symfony version(s) affected: 4.1.3

Description
In Symfony Profiler i can see that Doctrine\Common\ClassLoader is deprecated. And in the trace i can see, that it refers to the Repository of one of the classes, that was autogenerated with the Entity. And it refers to the string where is called parent construct of the class ServiceEntityRepository. Could you please provide some instructions how could i get rid of this notice in profiler?

How to reproduce
image

image

@xabbuh
Copy link
Member

@xabbuh xabbuh commented Aug 3, 2018

This was fixed in Doctrine ORM (see doctrine/orm#7326) but not released yet. I am closing here as there is nothing we can do in Symfony.

@xabbuh xabbuh closed this Aug 3, 2018
@OtezVikentiy
Copy link
Author

@OtezVikentiy OtezVikentiy commented Aug 3, 2018

Thanks a lot, guys! )))

@ragboyjr
Copy link
Contributor

@ragboyjr ragboyjr commented Aug 29, 2018

I was able to remove this warning by strictly requiring: "doctrine/common": "2.8.1" for now.

@crabnky
Copy link

@crabnky crabnky commented Aug 30, 2018

Hmm, I have 2.9.0 and still can see this deprecation in the profiler...

@GuillaumeSTEIN
Copy link

@GuillaumeSTEIN GuillaumeSTEIN commented Aug 30, 2018

@crabnky As suggested by @ragboyjr, I have set "doctrine/common": "2.8.1", and not ^2.9 and the deprecation is now fixed.

@stof
Copy link
Member

@stof stof commented Aug 30, 2018

@crabnky this deprecation is precisely triggered when you have doctrine/common 2.9.0 (because the 2.9.0 release is the one adding the warnings, and the fix in the ORM is not released)

@crabnky
Copy link

@crabnky crabnky commented Sep 4, 2018

Oh, thanks, understood. Do you know when the new version is planned to be released?

@stof
Copy link
Member

@stof stof commented Sep 4, 2018

no. That's something you need to ask to the Doctrine ORM maintainers.

@symfony symfony locked and limited conversation to collaborators Sep 4, 2018
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants
You can’t perform that action at this time.