Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fixed bug that incorrectly causes the "required" attribute to be omitted from select even though it contains the "multiple" attribute #10491

Closed
wants to merge 1 commit into from

Conversation

Projects
None yet
1 participant
@fabpot
Copy link
Member

commented Mar 19, 2014

According to the HTML5 specification the required attribute should be allowed in this case: "A select element with a required attribute and without a multiple attribute, and whose size is “1”, must have a child option element."

Related PR: #9030

Q A
Bug fix? yes
New feature? no
BC breaks? no
Deprecations? no
Tests pass? yes
License MIT
Fixed bug that incorrectly causes the "required" attribute to be omit…
…ted from select even though it contains the "multiple" attribute

fabpot added a commit that referenced this pull request Mar 19, 2014

bug #10491 Fixed bug that incorrectly causes the "required" attribute…
… to be omitted from select even though it contains the "multiple" attribute (fabpot)

This PR was submitted for the 2.4 branch but it was merged into the 2.3 branch instead (closes #10491).

Discussion
----------

Fixed bug that incorrectly causes the "required" attribute to be omitted from select even though it contains the "multiple" attribute

According to the HTML5 specification the required attribute should be allowed in this case: "A select element with a required attribute and **without** a multiple attribute, and whose size is “1”, must have a child option element."

Related PR: #9030

| Q             | A
| ------------- | ---
| Bug fix?      | yes
| New feature?  | no
| BC breaks?    | no
| Deprecations? | no
| Tests pass?   | yes
| License       | MIT

Commits
-------

f9aa676 Fixed bug that incorrectly causes the "required" attribute to be omitted from select even though it contains the "multiple" attribute

@fabpot fabpot closed this Mar 19, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.