Use 0.0.0.0 as the server log command host default. #22768

Merged
merged 1 commit into from May 19, 2017

Conversation

Projects
None yet
4 participants
@ChadSikorra
Contributor

ChadSikorra commented May 19, 2017

Q A
Branch? 3.3
Bug fix? yes
New feature? no
BC breaks? no
Deprecations? no
Tests pass? -
Fixed tickets -
License MIT

This fixes the server:log command on Windows when run with default settings. The current setting 0 has no meaning on Windows, and 0.0.0.0 is the standard "listen on all addresses/interfaces", so should be the most compatible. It works on both Linux and Windows for me this way.

I mentioned this in another PR where the logger config has the same issue on Windows:

symfony/symfony-standard#1077

@stof stof requested a review from lyrixx May 19, 2017

@lyrixx

This comment has been minimized.

Show comment
Hide comment
@lyrixx

lyrixx May 19, 2017

Member

I did not know 0 was not valid on windows. I'm sorry about that. @ChadSikorra Thanks for finding this error.

👍

Member

lyrixx commented May 19, 2017

I did not know 0 was not valid on windows. I'm sorry about that. @ChadSikorra Thanks for finding this error.

👍

@lyrixx

lyrixx approved these changes May 19, 2017

@nicolas-grekas nicolas-grekas added this to the 3.3 milestone May 19, 2017

@fabpot

This comment has been minimized.

Show comment
Hide comment
@fabpot

fabpot May 19, 2017

Member

Thank you @ChadSikorra.

Member

fabpot commented May 19, 2017

Thank you @ChadSikorra.

@fabpot fabpot merged commit 3fcc810 into symfony:3.3 May 19, 2017

2 of 3 checks passed

continuous-integration/appveyor/pr AppVeyor build failed
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
fabbot.io Your code looks good.
Details

fabpot added a commit that referenced this pull request May 19, 2017

bug #22768 Use 0.0.0.0 as the server log command host default. (ChadS…
…ikorra)

This PR was merged into the 3.3 branch.

Discussion
----------

Use 0.0.0.0 as the server log command host default.

| Q             | A
| ------------- | ---
| Branch?       | 3.3
| Bug fix?      | yes
| New feature?  | no
| BC breaks?    | no
| Deprecations? | no
| Tests pass?   | -
| Fixed tickets | -
| License       | MIT

This fixes the `server:log` command on Windows when run with default settings. The current setting `0` has no meaning on Windows, and `0.0.0.0` is the standard "listen on all addresses/interfaces", so should be the most compatible. It works on both Linux and Windows for me this way.

I mentioned this in another PR where the logger config has the same issue on Windows:

symfony/symfony-standard#1077

Commits
-------

3fcc810 Use 0.0.0.0 as the server log host default.

@fabpot fabpot referenced this pull request May 29, 2017

Merged

Release v3.3.0 #22949

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment