Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Form] Fix debug form when using partial type name #30509

Merged
merged 1 commit into from Mar 13, 2019

Conversation

Projects
None yet
5 participants
@yceruto
Copy link
Contributor

yceruto commented Mar 10, 2019

Q A
Branch? master
Bug fix? yes
New feature? no
BC breaks? no
Deprecations? no
Tests pass? yes
Fixed tickets -
License MIT

Since #29452 (4.3) we have the possibility of passing a partial type name. This fixes the case where debug:form dateTime doesn't work as expected:

In FormRegistry.php line 89:
                                                                                                        
  [Symfony\Component\Form\Exception\InvalidArgumentException]                                           
  Could not load type "dateTime": class does not implement "Symfony\Component\Form\FormTypeInterface". 

@nicolas-grekas nicolas-grekas added this to the next milestone Mar 10, 2019

@nicolas-grekas

This comment has been minimized.

Copy link
Member

nicolas-grekas commented Mar 13, 2019

Thank you @yceruto.

@nicolas-grekas nicolas-grekas merged commit 22b20ca into symfony:master Mar 13, 2019

3 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
fabbot.io Your code looks good.
Details

nicolas-grekas added a commit that referenced this pull request Mar 13, 2019

bug #30509 [Form] Fix debug form when using partial type name (yceruto)
This PR was merged into the 4.3-dev branch.

Discussion
----------

[Form] Fix debug form when using partial type name

| Q             | A
| ------------- | ---
| Branch?       | master
| Bug fix?      | yes
| New feature?  | no
| BC breaks?    | no
| Deprecations? | no
| Tests pass?   | yes
| Fixed tickets | -
| License       | MIT

Since #29452 (4.3) we have the possibility of passing a partial type name. This fixes the case where `debug:form dateTime` doesn't work as expected:
```bash
In FormRegistry.php line 89:

  [Symfony\Component\Form\Exception\InvalidArgumentException]
  Could not load type "dateTime": class does not implement "Symfony\Component\Form\FormTypeInterface".
```

Commits
-------

22b20ca Fix debug:form dateTime

@yceruto yceruto deleted the yceruto:fix_debug_form branch Mar 13, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.