Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Several components are incompatible with HttpKernel 5.0 #31890

Merged

Conversation

Projects
None yet
5 participants
@Simperfit
Copy link
Contributor

commented Jun 6, 2019

Q A
Branch? 4.4
Bug fix? no
New feature? no
BC breaks? no
Deprecations? no
Tests pass? yes
Fixed tickets none
License MIT
Doc PR none

This will help to finish the HttpKernel dead code removal (#31672) as this conflict with the component since the type-hint of several listener has been updated.

@nicolas-grekas nicolas-grekas added this to the next milestone Jun 6, 2019

@Simperfit Simperfit force-pushed the Simperfit:httpkernel/conflict-with-component branch from 3cd5c0e to 8c73b90 Jun 6, 2019

Show resolved Hide resolved src/Symfony/Bundle/FrameworkBundle/composer.json Outdated
Show resolved Hide resolved src/Symfony/Bundle/TwigBundle/composer.json Outdated
@@ -18,7 +18,7 @@
"require": {
"php": "^7.1.3",
"symfony/config": "^4.2|^5.0",
"symfony/http-kernel": "^4.3|^5.0",
"symfony/http-kernel": "^4.3",

This comment has been minimized.

Copy link
@stof

stof Jun 6, 2019

Member

Would other projects be affected in the same way ? This would tell me that we miss a migration path here.

This comment has been minimized.

Copy link
@nicolas-grekas

nicolas-grekas Jun 6, 2019

Member

The issue exists only if listener methods are extensibility point by inheritance. That's not the case most of the time, and even if it is, there are ways around.

This comment has been minimized.

Copy link
@stof

stof Jun 6, 2019

Member

great that we marked our listeners as @final to avoid similar issues in the future...

@@ -20,7 +20,7 @@
"ext-xml": "*",
"symfony/config": "^4.2|^5.0",
"symfony/dependency-injection": "^4.2|^5.0",
"symfony/http-kernel": "^4.3|^5.0",
"symfony/http-kernel": "^4.3",
@@ -19,7 +19,7 @@
"php": "^7.1.3",
"symfony/security-core": "^4.3",
"symfony/http-foundation": "^3.4|^4.0|^5.0",
"symfony/http-kernel": "^4.3|^5.0",
"symfony/http-kernel": "^4.3",

@Simperfit Simperfit force-pushed the Simperfit:httpkernel/conflict-with-component branch from 8c73b90 to 321a416 Jun 6, 2019

@Simperfit Simperfit force-pushed the Simperfit:httpkernel/conflict-with-component branch from 321a416 to a0e4ad3 Jun 6, 2019

@nicolas-grekas

This comment has been minimized.

Copy link
Member

commented Jun 6, 2019

Thank you @Simperfit.

@nicolas-grekas nicolas-grekas merged commit a0e4ad3 into symfony:4.4 Jun 6, 2019

1 of 3 checks passed

continuous-integration/appveyor/pr Waiting for AppVeyor build to complete
Details
continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
fabbot.io Your code looks good.
Details

nicolas-grekas added a commit that referenced this pull request Jun 6, 2019

minor #31890 Several components are incompatible with HttpKernel 5.0 …
…(Simperfit)

This PR was merged into the 4.4 branch.

Discussion
----------

Several components are incompatible with HttpKernel 5.0

| Q             | A
| ------------- | ---
| Branch?       | 4.4
| Bug fix?      | no
| New feature?  | no <!-- please update src/**/CHANGELOG.md files -->
| BC breaks?    | no     <!-- see https://symfony.com/bc -->
| Deprecations? | no <!-- please update UPGRADE-*.md and src/**/CHANGELOG.md files -->
| Tests pass?   | yes    <!-- please add some, will be required by reviewers -->
| Fixed tickets | none   <!-- #-prefixed issue number(s), if any -->
| License       | MIT
| Doc PR        | none <!-- required for new features -->

<!--
Replace this notice by a short README for your feature/bugfix. This will help people
understand your PR and can be used as a start for the documentation.

Additionally (see https://symfony.com/roadmap):
 - Bug fixes must be submitted against the lowest maintained branch where they apply
   (lowest branches are regularly merged to upper ones so they get the fixes too).
 - Features and deprecations must be submitted against branch 4.4.
 - Legacy code removals go to the master branch.
-->

This will help to finish the HttpKernel dead code removal (#31672) as this conflict with the component since the type-hint of several listener has been updated.

Commits
-------

a0e4ad3 Several components are incompatible with HttpKernel 5.0

@Simperfit Simperfit deleted the Simperfit:httpkernel/conflict-with-component branch Jun 6, 2019

@Tobion

Tobion approved these changes Jun 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.