Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

File Operations #489

Closed
iowaplayer opened this Issue Jan 24, 2018 · 27 comments

Comments

5 participants
@iowaplayer
Copy link

iowaplayer commented Jan 24, 2018

I'm running Synfig 1.2.1. on Windows 7

Whenever I try to open, save or import a file, i get an error pop up that says:
There is no disk in the drive. Please insert a disk into drive \Device\Harddisk5\DR5.

i have to click on cancel an average of 15 times before the error will go away and allow me to open, save or import a file.

Also, there seems no way in Preferences to set default paths to open, save or import.

I'm new to Synfig and am really enjoying it. It's very frustrating to have to go through this routine everytime i want to do something.

iowaplayer

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 24, 2018

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 24, 2018

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 24, 2018

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 24, 2018

no, the error shows up every time i click file, then select open, save or import. i'm not trying to do any path choosing. once i get rid of the error by clicking cancel about 15 times, it will allow me to select directories until i get to the one i want.

i'm not familiar with gtk3 software. what is that?

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 24, 2018

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 24, 2018

okay, i'll see what i can do. thank you so much for your help! :)

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 24, 2018

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 24, 2018

Yeah, seems to be quite popular issue. Beep6581/RawTherapee#3544 , https://answers.launchpad.net/inkscape/+question/129939 . Solutions vary from fixing "recently used files" list (see second link) to building on certain partition (you can try 1.3.5 build for now).

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 25, 2018

i'm not real sure how the solutions you referenced apply to me as i don't have any usb drives. i do have a c drive and an x drive, internal through my hard disk card.
the error occurs anytime i try to save, open or import, regardless of whether its for a new file or one i've modified.
i downloaded gimp 2.8.22 and it has no problems with saving, opening or exporting so it doesn't appear to be a gtk problem.
sad to say, while i do know a tiny bit about software, i'm not at the level to be able to do the fixes the guys in those two references you sent me.
also, as far as i can tell, there's no way to select what version of synfig i download from the synfig.org website. i can pick the current "stable version" or whatever their current development version is.

by the way, thanks for directing me to gtk. i ended up downloading gimp and it is AWESOME! i've been using microsoft visio and artrage 4 for my graphics and gimp opens up a whole new world! :)

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 25, 2018

@caryoscelus

This comment has been minimized.

Copy link
Collaborator

caryoscelus commented Jan 25, 2018

Oh, and i also forgot to mention that you can download builds on https://github.com/synfig/synfig/releases, though i suppose you were already able to download something.

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Jan 26, 2018

Once I've had similar issue with our build of OpenToonz. So it seems that's not related with Gtk3 (OpenToonz is on QT).

@iowaplayer Please open a window showing your disc drives (usually called 'Computer") and post screenshot here.

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 26, 2018

image

here is the current configuration of my computer.

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Jan 29, 2018

Hello @iowaplayer! Apologies for delayed reply.

I have investigated the problem. It looks like this issue is pretty common for various applications, even for Adobe products:

So, this problem is related with some OS internals.

It worths to look at this particular answer - https://forums.adobe.com/message/9451020#9451020

So, my questions:

  1. Please let me know if you have any card reader device in your system?
  2. Please try to insert any disc into your D: drive, start Synfig and try to save/open file. Does the problem appears again?
@morevnaproject

This comment has been minimized.

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 30, 2018

@iowaplayer

This comment has been minimized.

Copy link
Author

iowaplayer commented Jan 30, 2018

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Jan 31, 2018

Hello @iowaplayer !

i don't have a D: drive on my system

You do have one. I can see it on the image.
screenshot_001

Please try to insert any disc (CD or DVD) into your D: drive, start Synfig and try to save/open file. Does the problem appears again?

i opened the device manager and discovered that under hard disks i had:
Compact Flash USB Device located on USB Mass Storage
MS/MS-PRO USB Device located on H: Drive
SD/MMC USB Device located on G: Drive

Thank you for this information! This actually indicates, that you DO have a card-reader device in your system. Please take a look carefully at the corpus of your PC. Do you see any slots to insert SD/MMC cards? It is possible the card-reader is mounted directly into corpus body.

is there a difference in how open recent works compared to how open, save and import work?

Yes, opening through recent files menu doesn't involves listing files. That's why it doesn't asks for missing disc.

@Bill-Jobss

This comment has been minimized.

Copy link

Bill-Jobss commented Jan 31, 2019

Hi,

I have the same problem. So far I tried Synfig Studio 1.2.2, 1.3.10, and 1.3.11, and it happens every time I try to open or save a file. In version 1.3.11 the error message appears right after the program start. I have to click "Cancel" more than 20 times in order to close the message. I have a Windows 7 SP1 desktop with a card reader, DVD-drive and seven USB ports.

I never had such a problem with any other programs. Recent Files history is turned "off".

@BobSynfig

This comment has been minimized.

Copy link
Collaborator

BobSynfig commented Jan 31, 2019

Let's check this: Beep6581/RawTherapee#3544 (comment)

@Bill-Jobss

This comment has been minimized.

Copy link

Bill-Jobss commented Feb 1, 2019

I am glad that you guys are trying to maybe solve this bug. Let me know if you need any checking on my side.

A few observations that I made:

I tried to start Synfig Studio 1.3.11 when a SD card was in the card reader, it did not help, the error message appeared right after the program start. Each time I clicked "Cancel", it reappeared with a different drive number (sometimes with the same number).

Then I tried to start Synfig Studio when a DVD disk was in the DVD drive. The message did not appear at all neither with the version 1.3.11, nor with the version 1.2.2.

I took the DVD disk out of the drive, and the message started to appear again, but this time it was a different message. It said: "There is no disk in the drive. Please insert a disk into drive F:", and it did not change after I clicked "Cancel", it was the exact same message every time. Now it takes "only" 5 to 7 clicks to completely get rid of the message (before it was over 20). "F" is my DVD-drive letter.

I prefer not to keep DVDs in the drive when I am not using them, so it still would be great if you could resolve the issue.

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Feb 3, 2019

Then I tried to start Synfig Studio when a DVD disk was in the DVD drive. The message did not appear at all neither with the version 1.3.11, nor with the version 1.2.2.

Thank you for investigation - this note about DVD drive a very important information for us.

@BobSynfig Thank you, I think this could work!

morevnaproject added a commit that referenced this issue Feb 7, 2019

morevnaproject added a commit that referenced this issue Feb 7, 2019

morevnaproject added a commit that referenced this issue Feb 7, 2019

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Feb 7, 2019

@BobSynfig I have applied the fix you found! ^__^

@Bill-Jobss Can you please test if this special build will give you "no disk in the drive" errors? - https://downloads.synfig.org/almost-1.3.11/SynfigStudio-1.3.10-testing-19.02.07-win64-47da2-seterrormode.zip

@morevnaproject morevnaproject self-assigned this Feb 7, 2019

@BobSynfig

This comment has been minimized.

Copy link
Collaborator

BobSynfig commented Feb 7, 2019

In fact, it was initially found by @caryoscelus, I just "focused" on a specific comment ;)

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Feb 7, 2019

Ah, I has skipped the links in his comments because of the last sentence. ^__^

@Bill-Jobss

This comment has been minimized.

Copy link

Bill-Jobss commented Feb 7, 2019

Wow! You fixed it. No error messages neither after the program start, nor when opening or saving a project file. Thank you. Good job. So, approximately when do you expect the 1.3.11 will be ready?

@morevnaproject

This comment has been minimized.

Copy link
Member

morevnaproject commented Feb 8, 2019

Thank you for testing!

I am building packages for 1.3.11 right now. Hopefully, will finish all release procedures this week. ^__^
Please consider, that it is going to be a development version - i.e. it still could have other issues and might not be ready for production use.

@morevnaproject morevnaproject added this to Done in Releases Feb 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.