Skip to content
This repository has been archived by the owner. It is now read-only.
very basic elasticsearch module
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
manifests
spec
templates
.gitignore
.travis.yml
Gemfile
LICENSE.txt
Modulefile
README.md
Rakefile

README.md

#elasticsearch

Build Status

##Overview

A Puppet module to install elasticsearch.

Supported plattforms:

  • Debian 7
  • Ubuntu 12.04
  • Ubuntu 14.04
  • CentOS 6.5

There is an implicit dependency to java - make sure to setup java properly before using this module!

Installation

This modules depends on:

So all repositories have to be checked out:

git clone https://github.com/synyx/puppet-elasticsearch.git modules/elasticsearch
git clone https://github.com/puppetlabs/puppetlabs-apt.git modules/apt
git clone https://github.com/puppetlabs/puppetlabs-stdlib.git modules/stdlib

##Usage

class { 'elasticsearch':}

Authors

License

puppet-elasticsearch is released under the MIT License. See the bundled LICENSE file for details.

You can’t perform that action at this time.