Shockwave Flash Player version utility
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
npm-swf-player-version
LICENSE
README.md
bower.json
package.json
swf-player-version.js
swf-player-version.min.js

README.md

SWFPlayerVersion

Shockwave Flash Player version utility. GCC ADVANCED optimizations compatible.

// Test if SWF Player version is supported and output the actual version.
if (SWFPlayerVersion.isSupported('10.0')) {
  alert('SWF Player ' + SWFPlayerVersion.get() + ' is installed');
}

API

get()
  returns {?string} '#.#.#' or null.

  Get available SWF Player version. Result is cached.
isSupported(requiredString)
  requiredString {string} '#.#.#', '#.#', '#' or ''.
  returns {boolean} true if supported.

  Determine if available SWF Player meets version requirement.