New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

systemd-udevd: Failed to wait spawned #11341

Closed
kouros17 opened this Issue Jan 6, 2019 · 4 comments

Comments

4 participants
@kouros17
Copy link

kouros17 commented Jan 6, 2019

I'm using manjaro and gnome desktop (with gdm) and I’m getting the following warning in the journal after the systemd 240.1-2 until now 240.58-1

systemd-udevd[464]: Failed to wait spawned command '/usr/bin/alsactl restore 1': Input/output error
systemd-udevd[446]: Failed to wait spawned command '/usr/bin/alsactl restore 0': Input/output error

I managed to resolve it by following the instructions from here although I’m not sure if it’s a real fix or a workaround.

@yuwata

This comment has been minimized.

Copy link
Member

yuwata commented Jan 6, 2019

Do you mean that the udev rules work with v239 but not with v240? If so, please provide debugging logs of udevd.

@kouros17

This comment has been minimized.

Copy link

kouros17 commented Jan 7, 2019

How I can provide debugging logs of udevd?
What do you think about this fix?

@keszybz

This comment has been minimized.

Copy link
Member

keszybz commented Jan 7, 2019

What do you think about this fix?

I'm sorry, but it's not a fix at all. It just disables the functionality.

Please run udev with debugging enabled (put udev_log=debug in /etc/udev/udev.conf), and paste the logs here.

@kouros17

This comment has been minimized.

Copy link

kouros17 commented Jan 10, 2019

The issue resolved with systemd 240.156-1 👍
Thanks a lot @keszybz!

@kouros17 kouros17 closed this Jan 10, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment