New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

core/mount: make mount_setup_existing_unit() not drop MOUNT_PROC_JUST_MOUNTED flag from units #11364

Merged
merged 1 commit into from Jan 9, 2019

Conversation

3 participants
@yuwata
Copy link
Member

yuwata commented Jan 8, 2019

This fixes a bug introduced by ec88d1e.

Fixes #11362.

(I've not confirmed whether this actually fixes the issue or not...)

@yuwata yuwata added the pid1 label Jan 8, 2019

core/mount: make mount_setup_existing_unit() not drop MOUNT_PROC_JUST…
…_MOUNTED flag from units

This fixes a bug introduced by ec88d1e.

Fixes #11362.
@Maryse47

This comment has been minimized.

Copy link

Maryse47 commented Jan 8, 2019

I tested that it fixes mentioned issue.

@keszybz

This comment has been minimized.

Copy link
Member

keszybz commented Jan 9, 2019

Somehow I find this whole function not very pretty. But the fix looks correct. Let's merge.

@keszybz keszybz merged commit d253a45 into systemd:master Jan 9, 2019

8 of 9 checks passed

bionic-i386 autopkgtest running
Details
CentOS CI Build finished.
Details
LGTM analysis: C/C++ No alert changes
Details
LGTM analysis: JavaScript No code changes detected
Details
LGTM analysis: Python No code changes detected
Details
bionic-amd64 autopkgtest finished (success)
Details
bionic-s390x autopkgtest finished (success)
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
semaphoreci The build passed on Semaphore.
Details

@yuwata yuwata deleted the yuwata:fix-11362 branch Jan 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment