Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CVE-2017-16129 (Medium) detected in superagent-1.8.5.tgz, superagent-0.21.0.tgz #21

Open
whitesource-bolt-for-github bot opened this issue May 6, 2019 · 1 comment

Comments

Projects
None yet
0 participants
@whitesource-bolt-for-github
Copy link

commented May 6, 2019

CVE-2017-16129 - Medium Severity Vulnerability

Vulnerable Libraries - superagent-1.8.5.tgz, superagent-0.21.0.tgz

superagent-1.8.5.tgz

elegant & feature rich browser / node HTTP with a fluent API

Library home page: https://registry.npmjs.org/superagent/-/superagent-1.8.5.tgz

Path to dependency file: /cypress/packages/https-proxy/package.json

Path to vulnerable library: /tmp/git/cypress/packages/https-proxy/node_modules/superagent/package.json

Dependency Hierarchy:

  • supertest-1.2.0.tgz (Root Library)
    • superagent-1.8.5.tgz (Vulnerable Library)
superagent-0.21.0.tgz

elegant & feature rich browser / node HTTP with a fluent API

Library home page: https://registry.npmjs.org/superagent/-/superagent-0.21.0.tgz

Path to dependency file: /cypress/packages/server/package.json

Path to vulnerable library: /tmp/git/cypress/packages/server/node_modules/superagent/package.json

Dependency Hierarchy:

  • supertest-0.15.0.tgz (Root Library)
    • superagent-0.21.0.tgz (Vulnerable Library)

Found in HEAD commit: 29dcad339d37f2169e5a640bf8d0d1438f7c18c2

Vulnerability Details

The HTTP client module superagent is vulnerable to ZIP bomb attacks. In a ZIP bomb attack, the HTTP server replies with a compressed response that becomes several magnitudes larger once uncompressed. If a client does not take special care when processing such responses, it may result in excessive CPU and/or memory consumption. An attacker might exploit such a weakness for a DoS attack. To exploit this the attacker must control the location (URL) that superagent makes a request to.

Publish Date: 2018-06-07

URL: CVE-2017-16129

CVSS 3 Score Details (5.9)

Base Score Metrics:

  • Exploitability Metrics:
    • Attack Vector: Network
    • Attack Complexity: High
    • Privileges Required: None
    • User Interaction: None
    • Scope: Unchanged
  • Impact Metrics:
    • Confidentiality Impact: None
    • Integrity Impact: None
    • Availability Impact: High

For more information on CVSS3 Scores, click here.

Suggested Fix

Type: Upgrade version

Origin: https://nvd.nist.gov/vuln/detail/CVE-2017-16129

Release Date: 2019-04-08

Fix Resolution: 3.7.0


Step up your Open Source Security Game with WhiteSource here

@issue-label-bot

This comment has been minimized.

Copy link

commented May 6, 2019

Issue-Label Bot is automatically applying the label bug to this issue, with a confidence of 0.86. Please mark this comment with 👍 or 👎 to give our bot feedback!

Links: app homepage, dashboard and code for this bot.

@issue-label-bot issue-label-bot bot added the bug label May 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.