Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WS-2017-0131 (Medium) detected in jquery-2.2.4.tgz #29

Open
whitesource-bolt-for-github bot opened this issue May 6, 2019 · 1 comment

Comments

Projects
None yet
0 participants
@whitesource-bolt-for-github
Copy link

commented May 6, 2019

WS-2017-0131 - Medium Severity Vulnerability

Vulnerable Library - jquery-2.2.4.tgz

JavaScript library for DOM operations

Library home page: https://registry.npmjs.org/jquery/-/jquery-2.2.4.tgz

Path to dependency file: /cypress/packages/driver/package.json

Path to vulnerable library: /cypress/packages/driver/node_modules/jquery/package.json

Dependency Hierarchy:

  • jquery-2.2.4.tgz (Vulnerable Library)

Found in HEAD commit: 29dcad339d37f2169e5a640bf8d0d1438f7c18c2

Vulnerability Details

Affected versions of the jQuery package (1.4.0 through 1.11.3 and 1.12.4 through 2.2.4), are vulnerable to XSS attacks.

Publish Date: 2017-04-03

URL: WS-2017-0131

CVSS 2 Score Details (4.3)

Base Score Metrics not available

Suggested Fix

Type: Upgrade version

Origin: jquery/jquery@b078a62

Release Date: 2019-04-08

Fix Resolution: 1.11.4,2.2.5


Step up your Open Source Security Game with WhiteSource here

@issue-label-bot

This comment has been minimized.

Copy link

commented May 6, 2019

Issue-Label Bot is automatically applying the label bug to this issue, with a confidence of 0.97. Please mark this comment with 👍 or 👎 to give our bot feedback!

Links: app homepage, dashboard and code for this bot.

@issue-label-bot issue-label-bot bot added the bug label May 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.