Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CVE-2017-18342 (High) detected in netdata-v1.5.0 #47

Open
whitesource-bolt-for-github bot opened this issue May 6, 2019 · 1 comment

Comments

Projects
None yet
0 participants
@whitesource-bolt-for-github
Copy link

commented May 6, 2019

CVE-2017-18342 - High Severity Vulnerability

Vulnerable Library - netdatav1.5.0

Real-time performance monitoring, done right! https://my-netdata.io/

Library home page: https://github.com/netdata/netdata.git

Found in HEAD commit: 29dcad339d37f2169e5a640bf8d0d1438f7c18c2

Library Source Files (16)

* The source files were matched to this source library based on a best effort match. Source libraries are selected from a list of probable public libraries.

  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/error.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/emitter.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/reader.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/serializer.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/dumper.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/constructor.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/tokens.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/resolver.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/representer.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/events.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/nodes.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/composer.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/loader.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/cyaml.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/scanner.py
  • /cypress/packages/driver/node_modules/js-yaml/support/pyyaml-src/parser.py

Vulnerability Details

In PyYAML before 4.1, the yaml.load() API could execute arbitrary code. In other words, yaml.safe_load is not used.

Publish Date: 2018-06-27

URL: CVE-2017-18342

CVSS 3 Score Details (9.8)

Base Score Metrics:

  • Exploitability Metrics:
    • Attack Vector: Network
    • Attack Complexity: Low
    • Privileges Required: None
    • User Interaction: None
    • Scope: Unchanged
  • Impact Metrics:
    • Confidentiality Impact: High
    • Integrity Impact: High
    • Availability Impact: High

For more information on CVSS3 Scores, click here.

Suggested Fix

Type: Upgrade version

Origin: https://nvd.nist.gov/vuln/detail/CVE-2017-18342

Release Date: 2018-06-27

Fix Resolution: 4.1


Step up your Open Source Security Game with WhiteSource here

@issue-label-bot

This comment has been minimized.

Copy link

commented May 6, 2019

Issue-Label Bot is automatically applying the label bug to this issue, with a confidence of 0.72. Please mark this comment with 👍 or 👎 to give our bot feedback!

Links: app homepage, dashboard and code for this bot.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.