Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update express and http-proy. Add ejs and express-partials to fix vie…

…w rendering in express 3.0.
  • Loading branch information...
commit 9203195e7fb620de73c2de075aada59cf86ba776 1 parent 7e2e86e
Szymon Nowak authored
Showing with 43 additions and 15 deletions.
  1. +1 −0  .gitignore
  2. +35 −12 npm-shrinkwrap.json
  3. +4 −2 package.json
  4. +3 −1 server.js
1  .gitignore
View
@@ -0,0 +1 @@
+/node_modules
47 npm-shrinkwrap.json
View
@@ -3,50 +3,73 @@
"version": "1.0.0",
"dependencies": {
"express": {
- "version": "3.0.0beta2",
+ "version": "3.0.0rc3",
"dependencies": {
"connect": {
- "version": "2.3.1",
+ "version": "2.4.3",
"dependencies": {
"qs": {
"version": "0.4.2"
},
- "mime": {
- "version": "1.2.4"
- },
"formidable": {
- "version": "1.0.9"
+ "version": "1.0.11"
+ },
+ "bytes": {
+ "version": "0.1.0"
+ },
+ "pause": {
+ "version": "0.0.1"
}
}
},
"commander": {
"version": "0.6.1"
},
- "mime": {
- "version": "1.2.5"
+ "range-parser": {
+ "version": "0.0.4"
},
"mkdirp": {
- "version": "0.3.2"
+ "version": "0.3.3"
},
"cookie": {
- "version": "0.0.3"
+ "version": "0.0.4"
},
"crc": {
"version": "0.2.0"
},
+ "fresh": {
+ "version": "0.1.0"
+ },
+ "methods": {
+ "version": "0.0.1"
+ },
+ "send": {
+ "version": "0.0.3",
+ "dependencies": {
+ "mime": {
+ "version": "1.2.6"
+ }
+ }
+ },
"debug": {
"version": "0.7.0"
}
}
},
+ "ejs": {
+ "version": "0.8.2"
+ },
+ "express-partials": {
+ "version": "0.0.5"
+ },
"http-proxy": {
- "version": "0.8.1",
+ "version": "0.8.2",
"dependencies": {
"colors": {
"version": "0.6.0-1"
},
"optimist": {
- "version": "0.2.8",
+ "version": "0.3.4",
"dependencies": {
"wordwrap": {
"version": "0.0.2"
6 package.json
View
@@ -2,7 +2,9 @@
"name": "xmpp-bosh-interface-proxy"
, "version": "1.0.0"
, "dependencies": {
- "express": "3.0.0beta2"
- , "http-proxy": "0.8.1"
+ "express": "3.0.0rc3"
+ , "ejs": "0.8.2"
+ , "express-partials": "0.0.5"
+ , "http-proxy": "0.8.2"
}
}
4 server.js
View
@@ -3,9 +3,10 @@
var util = require('util'),
express = require('express'),
+ partials = require('express-partials'),
httpProxy = require('http-proxy');
-var app = express.createServer(),
+var app = express(),
proxy = new httpProxy.HttpProxy({
target: {
host: 'localhost',
@@ -15,6 +16,7 @@ var app = express.createServer(),
app.configure(function() {
app.use(express.static(__dirname));
+ app.use(partials());
app.use(express.bodyParser());
app.use(express.cookieParser());
app.use(express.session({secret: 'f7cd7374c2851fb727582bf'}));
Please sign in to comment.
Something went wrong with that request. Please try again.