Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Ruby bindings for the GTK+ port of WebKit.

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 sample
Octocat-spinner-32 src
Octocat-spinner-32 .gitignore
Octocat-spinner-32 COPYING.LIB
Octocat-spinner-32 ChangeLog
Octocat-spinner-32 README
Octocat-spinner-32 Rakefile
Octocat-spinner-32 extconf.rb
Octocat-spinner-32 mkmf.log
README
RbWebKitGTK

These are usable bindings. There are still some methods missing 
from WebView, but you can use almost the whole API at this point.

To build:

  1. cd /path/to/rbwebkitgtk/
  2. export RG2_DIR=/path/to/ruby-gnome2-sources/; ruby extconf.rb
  3. make
  4. (as root) 
     make install 

To require:
  
  require 'webkit'

To use the WebView Gtk Widget:

  webview = Gtk::WebKit::WebView.new
  webview.open("http://www.example.com/")
   -or-
  webview.load_html_string("<h1>Hi!</h1>")

-------

This page sets out WebKit deps on ubuntu
http://packages.ubuntu.com/source/hardy/webkit

I've developing against nightly build WebKit-r31823 - dan
Something went wrong with that request. Please try again.