npm package broken #11

Open
singlow opened this Issue Sep 12, 2011 · 1 comment

Projects

None yet

2 participants

@singlow
singlow commented Sep 12, 2011

I installed via npm version 1.0.27 and node 0.4.9. The package.json file did not include a main entry, so require('gd') was broken. I added main: './gd.js', to my package.json and it worked.

Not sure if you maintain the npm package or not - it lists a forked repo, but you as the author.

@mikesmullin

the community-maintained version works:
https://github.com/mikesmullin/node-gd

this is also the version registered with npmjs.org
so you should also be able to do:

npm install node-gd

with success

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment