node removed node_event.h #13

Open
itugs opened this Issue Dec 19, 2011 · 5 comments

Projects

None yet

5 participants

@itugs

hello.

node.js seems to remove node_event.h.

have any patch plan?

thanks.

@panos-kosmidis

@itugs seems that no one cares about it... I have the same issue and same question with @itugs

Here is my output:

root@dev:/home/rnd/domains/design.rnd/public_html/app-ui# npm install node-gd
npm http GET https://registry.npmjs.org/node-gd
npm http 304 https://registry.npmjs.org/node-gd

> node-gd@0.1.8 install /home/rnd/domains/design.rnd/public_html/app-ui/node_modules/node-gd
> node-waf configure build

Checking for program g++ or c++          : /usr/bin/g++ 
Checking for program cpp                 : /usr/bin/cpp 
Checking for program ar                  : /usr/bin/ar 
Checking for program ranlib              : /usr/bin/ranlib 
Checking for g++                         : ok  
Checking for node path                   : not found 
Checking for node prefix                 : ok /usr/local 
'configure' finished successfully (0.520s)
Waf: Entering directory `/home/rnd/domains/design.rnd/public_html/app-ui/node_modules/node-gd/build'
[1/2] cxx: node-gd.cc -> build/Release/node-gd_1.o
../node-gd.cc:19:25: fatal error: node_events.h: No such file or directory
compilation terminated.
Waf: Leaving directory `/home/rnd/domains/design.rnd/public_html/app-ui/node_modules/node-gd/build'
Build failed:  -> task failed (err #1): 
    {task: cxx node-gd.cc -> node-gd_1.o}
npm ERR! error installing node-gd@0.1.8

npm ERR! node-gd@0.1.8 install: `node-waf configure build`
npm ERR! `sh "-c" "node-waf configure build"` failed with 1
npm ERR! 
npm ERR! Failed at the node-gd@0.1.8 install script.
npm ERR! This is most likely a problem with the node-gd package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-waf configure build
npm ERR! You can get their info via:
npm ERR!     npm owner ls node-gd
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System Linux 2.6.32-5-amd64
npm ERR! command "node" "/usr/local/bin/npm" "install" "node-gd"
npm ERR! cwd /home/rnd/domains/design.rnd/public_html/app-ui
npm ERR! node -v v0.6.8
npm ERR! npm -v 1.1.0-2
npm ERR! code ELIFECYCLE
npm ERR! message node-gd@0.1.8 install: `node-waf configure build`
npm ERR! message `sh "-c" "node-waf configure build"` failed with 1
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/rnd/domains/design.rnd/public_html/app-ui/npm-debug.log
npm not ok
@dhcode

I get exactly the same error with node v0.6.7

@panos-kosmidis

With node v0.6.9 I managed to install it but now I'm getting this:

root@dev:/home/rnd/domains/design.rnd/public_html/app-ui/apps/main# npm install pulverizr -g
npm http GET https://registry.npmjs.org/pulverizr
npm http 304 https://registry.npmjs.org/pulverizr
npm http GET https://registry.npmjs.org/coloured-log
npm http GET https://registry.npmjs.org/optimist
npm http GET https://registry.npmjs.org/promised-io
npm http 304 https://registry.npmjs.org/coloured-log
npm http 304 https://registry.npmjs.org/optimist
npm http 200 https://registry.npmjs.org/promised-io
npm http GET https://registry.npmjs.org/coloured
npm http GET https://registry.npmjs.org/log
npm http GET https://registry.npmjs.org/wordwrap
npm http 304 https://registry.npmjs.org/log
npm http 304 https://registry.npmjs.org/coloured
npm http 304 https://registry.npmjs.org/wordwrap
/usr/local/bin/pulverize -> /usr/local/lib/node_modules/pulverizr/cli.js
pulverizr@0.6.0 /usr/local/lib/node_modules/pulverizr 
├── promised-io@0.3.0
├── coloured-log@0.9.7 (coloured@0.2.0 log@1.2.0)
└── optimist@0.3.1
root@dev:/home/rnd/domains/design.rnd/public_html/app-ui/apps/main# pulverize -h

node.js:201
        throw e; // process.nextTick error, or 'error' event on first tick
              ^
Error: Cannot find module 'promised-io/lib/promise'
    at Function._resolveFilename (module.js:334:11)
    at Function._load (module.js:279:25)
    at Module.require (module.js:357:17)
    at require (module.js:373:17)
    at Object.<anonymous> (/usr/local/lib/node_modules/pulverizr/lib/job.js:4:15)
    at Module._compile (module.js:444:26)
    at Object..js (module.js:462:10)
    at Module.load (module.js:351:31)
    at Function._load (module.js:310:12)
    at Module.require (module.js:357:17)
@mikesmullin

this has been fixed in the community-maintained version. please try:
https://github.com/mikesmullin/node-gd

make sure to follow the README.md instructions.

@jmendeth

wow, lot's of changes make it difficult to follow the procedure...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment