Skip to content
Browse files

bump pycryptopp dependency to >=0.6.0, to get ed25519 signatures

This is for the upcoming #466 signed-introducer code.
  • Loading branch information...
1 parent e215af8 commit 0e60920bafb39a695c0b27a7c671890685a93d7b @warner warner committed
Showing with 2 additions and 12 deletions.
  1. +2 −12 src/allmydata/_auto_deps.py
View
14 src/allmydata/_auto_deps.py
@@ -76,18 +76,8 @@
def require_more():
import platform, sys
-
- if platform.machine().lower() in ['i386', 'x86', 'i686', 'x86_64', 'amd64', '']:
- # pycryptopp v0.5.20 fixes bugs in SHA-256 and AES on x86 or amd64
- # (from Crypto++ revisions 470, 471, 480, 492). The '' is there
- # in case platform.machine is broken and this is actually an x86
- # or amd64 machine.
- install_requires.append("pycryptopp >= 0.5.20")
- else:
- # pycryptopp v0.5.13 had a new bundled version of Crypto++
- # (v5.6.0) and a new bundled version of setuptools (although that
- # shouldn't make any difference to users of pycryptopp).
- install_requires.append("pycryptopp >= 0.5.14")
+ # pycryptopp-0.6.0 includes ed25519
+ install_requires.append("pycryptopp >= 0.6.0")
# Sqlite comes built into Python >= 2.5, and is provided by the "pysqlite"
# distribution for Python 2.4.

0 comments on commit 0e60920

Please sign in to comment.
Something went wrong with that request. Please try again.