Skip to content

常见问题

weishu edited this page Mar 1, 2019 · 14 revisions

Q:无法触发 Magisk 版?

A:建议使用 Magisk 17.x 版本。然后检查是否装有其他的 Magisk 模块,如果有请关闭其他模块再尝试。如果确认有冲突,反馈给我:https://github.com/tiann/EXposed/issues

Q:支持哪些模块?

A:原本太极支持的模块都支持,新增支持的模块(边缘手势/核心破解/应用变量/模拟位置/ACEnergy/抖音助手等)在群文件下载即可。

Q:太极与 Xposed 有何不同?

太极的设计理念上与 Xposed 有很多不同:

  1. 不强制拦截系统内所有APP,对于不希望使用 Xposed 的 APP ,太极几乎不做任何干涉。
  2. 弱侵入特性。太极减少了 Xposed 的很多特征,如 全局的 ClassLoader 中再也没有 Xposed 的身影,非侵入的 app_process 以及弱干涉的 ART。
  3. 太极内核可以随时升级,无需重新刷机,直接升级太极 APP 即可完成,可以即为快速地响应和解决 BUG。

当然,受限于 ART 的种种约束,在方法拦截方面,太极无法做到 Xposed 那样完美。有一些方法是无法被拦截的,但是,太极的拦截能力已经足够做出各种功能强大而完善的模块;但是需要开发者在挑选HOOK点的时候额外注意。

Q:为什么有些模块不支持?

  1. 因为 rovo89 的 Xposed 压根就不支持 9.0,因此模块都没有适配 9.0 系统。Android 9.0 系统发生了较大的变化,因此这些模块我自己尝试是无法正常工作的,可能导致无法开机,因此无法使用。另外,9.0 的SELinux 规则基本上废掉了 XSharedPreference,严重依赖 XSharedPerference的模块如果 target sdk 为28及以上,那么压根无法工作。
  2. 如上所述,Xposed 和 太极的机制实际上是完全不同的,有些模块过分使用了 Xposed 特有的特性(如反射内部类,特殊的成员,外部环境等);这些插件在太极中压根无法运行。

Q:为什么还是有模块限制?

A:实际上,Magisk 版不会对 公开的,非恶意的模块做任何限制;如果你有需要使用的模块,可以直接在本项目的 issue 提交给我。

Q:开放所有模块,能不能用让我们自己测试不就行了?

A:实际上,能折腾并且能理解和体谅开发者的用户凤毛菱角。很多用户(包括会刷机的)甚至连模块在哪里下载都不知道,太极中的模块下载是请求服务器数据的,有段时间服务器挂掉了,有的用户以为是太极 APP 出了问题,卸载重装,刷机,甚至恢复出厂设置。如果冒昧开放所有模块,而其中相当一部分模块无法使用,这些用户只会觉得 APP 垃圾,然后卸载。所以我必须明确告诉他们,哪些模块现在是不行的,哪些模块是可以用的。另外,太极支持免ROOT运行,大量连手机都不怎么会用的用户对我来说就是灾难。

Q:搞两个版本,一个全开,一个限制?

A:这跟只有一个全开的版本没有任何区别。

Q:为什么只有特定的模块版本才能生效,有的模块已经支持了为什么还要限制版本?

A:这一点是从模块开发者的角度考虑的。太极在加载模块的时候,会验证模块的来源,只有原作者发布的版本才能被加载和使用;这样可以有效地限制破解版和修改版,从而保护 Xposed 模块作者的权益。

  1. 我已经受够了所谓的 “破解版”,“美化版”,“清爽版”,实际上它们什么都没做,随便改个版本号就重新发布了,拿着模块作者的成果到处招摇撞骗。
  2. 如果模块是开源的,那么任何人都可以 fork 并且发布一个新的模块(并且还可以不开源);这使得作者可能会逐步丧失开源和维护的动力,导致模块停止维护。
  3. 如果模块选择闭源收费,那么由于 Xposed 模块的特殊性(无法加固等),使得模块很容易出现破解版,这使得模块作者的利益得到极大地损害。要么要花大力气与破解版做斗争,要么使得开发者弃坑。

在太极中,这一切都将不复存在。并且,你可以更新适配引擎来获取最新的插件支持。

Q:我是开发者,如何适配 太极·Magisk?

A:首先表示欢迎,然后感谢你们的付出。请加入私聊我然后加入开发者交流群。

Q:为什么模块无法生效?

A:有诸多原因,请逐一检查:

  1. 是否需要使用Xposed的APP添加到了太极中?
  2. 是否勾选了对应的模块?
  3. 某些模块需要重启手机,是否重启过?
  4. 某些模块只支持特定版本的APP,APP版本是否正确?
  5. 模块版本是否正确?请使用群文件中我上传的已经验证过的模块

注意:太极·Magisk版有一些使用方法与 Xposed 不同,请知悉:

  1. 必须把 APP 添加到太极中,太极才会对这个 APP 启用Xposed 功能。
  2. 不是作用于系统的模块,无需重启手机即可生效。
  3. 模块重新安装之后,需要重新勾选。

Q:为什么无法开机,卡 Logo?

A:请反馈给我,但是暂时可能无法解决;请先使用普通版太极。等我做好了日志模块,后续注意解决。

Q:为什么会出现阻止闪退?

A:这是太极自带的特性,忽略即可。理论上,如果模块自己没有做好,会导致APP闪退;太极给了APP一个不闪退的机会。并不代表太极本身出现了问题。

Q:黑阈太极之后工作不正常?

A:是的,黑阈太极之后可能会导致系统假死。请不要黑阈太极。另外,magisk 版的太极无需自启动,你无需黑阈它。

Q:我还有别的问题?

A:在github上提 issue,注意选择 issue 模版,尽量把问题描述清楚:https://github.com/tiann/EXposed/issues

You can’t perform that action at this time.