Skip to content
Compare
Choose a tag to compare

v3.0.0-alpha.2

Pre-release
Pre-release
@adamwathan adamwathan released this
· 33 commits to master since this release
Compare
Choose a tag to compare

To upgrade, install tailwindcss@next:

npm install -D tailwindcss@next

If you're using @tailwindcss/typography or @tailwindcss/forms, you'll want to update those packages as well:

npm install -D @tailwindcss/typography@next
npm install -D @tailwindcss/forms@next

Remember this is an alpha release, so some things might be broken. I don't know about them otherwise I would have fixed them, but you are gonna find them! So try it, break it, and tell me about it when you do so we can get this thing really battle-tested for a proper v3.0 release in a few weeks.


Changed

  • Don't use pointer cursor on disabled buttons by default (#5772)
  • Set default content value in preflight instead of within each before/after utility (#5820)
  • Remove prefix as a function (#5829)

Added

  • Add flex-basis utilities (#5671)
  • Make negative values a first-class feature (#5709)
  • Add fit-content values for min/max-width/height utilities (#5638)
  • Add min/max-content values for min/max-height utilities (#5729)
  • Add all standard cursor-* values by default (#5734)
  • Add grow-* and shrink-* utilities, deprecate flex-grow-* and flex-shrink-* (#5733)
  • Add text-decoration-color utilities (#5760)
  • Add new declarative addVariant API (#5809)
  • Add first-class print variant for targeting printed media (#5885)
  • Add full color palette for fill-* and stroke-* utilities (#5933)
  • Add composable API for colored box shadows (#5979)

Fixed

  • Configure chokidar's awaitWriteFinish setting to avoid occasional stale builds on Windows (#5774)
  • Fix CLI --content option (#5775)
  • Fix before/after utilities overriding custom content values at larger breakpoints (#5820)
  • Cleanup duplicate properties (#5830)
  • Allow _ inside url() when using arbitrary values (#5853)
  • Prevent crashes when using comments in @layer AtRules (#5854)
  • Handle color transformations properly with theme(...) for all relevant plugins (#4533, #5871)
  • Ensure @apply-ing a utility with multiple definitions works (#5870)

Thanks to everyone who contributed to this release: @adamwathan, @bradlc, @dance2die, @dcastil, @DoctorDerek, @hardfist, @lukewarlow, @MatteoGauthier, @MichaelAllenWarner, @nifte, @reinink, @RobinMalfait, @sachinraja, @xzfd1010 ❤️