Skip to content

Home

takuma104 edited this page Sep 13, 2010 · 8 revisions
Clone this wiki locally

iphone-rubycocoa: Ruby / RubyCocoa for the iPhone SDK

What’s this?

The screenshot (hello world sample)

It tells us nothing ;)

The ruby code for the app of screenshot above.

You can write some ruby code for almost like RubyCocoa (for Mac) way.

Source code

You can git-clone or download tarball from github, and can build the above sample app using iPhone SDK.

http://github.com/takuma104/iphone-rubycocoa/tree/master

  • License: same as Ruby (thus you can choose it as Ruby License)
  • Currently, I am confirming to build on the latest iPhone SDK 2.2.1 and iPhone/iPod touch 2.2.1.
  • IMPORTANT: You need to change Xcode project’s build settings to “Device 2.0” or “Simulator 2.0”.

It is based on Ruby 1.8.7 and RubyCocoa 0.4.2. RubyCocoa 0.4.2 is very old version, I choose it, because the latest 0.13.2 requires libffi library. I tried to build libffi but gave up finally. I chose the old one that doesn’t need libffi. Recently, JSCocoa team seems on success running libffi on the iPhone device.

Can/Can’t

This iphone-rubycocoa can now

  • Ruby: samples / test.rb almost passed. test / test_ *. rb is not tested. I sort of like moving the socket.
  • RubyCocoa: I have not tested too much. This hello world program passed anyway, at least ;)

This iphone-rubycocoa can not now

  • RubyCocoa: It doesn’t contain BridgeSupport so I’d like to backport it from the latest version

FAQ

  • Is it approved for the AppStore?
    • I haven’t submitted it yet ;)

Articles

Contact

Any feedback welcome.

takuma104@gmail.com

Something went wrong with that request. Please try again.