Skip to content
Permalink
Browse files

hopefully fix for Ruby 1.8

  • Loading branch information...
takuo committed Jun 8, 2011
1 parent 030eadb commit 832bacc3cb1b8a2c406a95973f440dcb0b0fe3ba
Showing with 3 additions and 2 deletions.
  1. +3 −2 compat.rb
@@ -9,11 +9,12 @@
#
begin
require 'oauth'
require 'hmac'
rescue LoadError
require 'rubygems'
require 'oauth'
require 'hmac'
end
require 'hmac'

# define Process.daemon (ruby 1.9 feature)
unless Process.respond_to?(:daemon)
@@ -54,7 +55,7 @@ def set_key(key)
module Unicode
def self.const_missing( codepoint )
if codepoint.to_s =~ /^([0-9a-fA-F]{4,5}|10[0-9a-fA-F]{4})$/
const_set(codepoint, [$1.to_i(16)].pack("U").freeze)
const_set( codepoint, [$1.to_i(16)].pack("U").freeze )
else
raise NameError, "Uninitialized constant: Unicode::#{codepoint}"
end

0 comments on commit 832bacc

Please sign in to comment.
You can’t perform that action at this time.