Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CVE-2019-8331 (Medium) detected in bootstrap-2.1.0.js #8

Open
whitesource-for-github-com bot opened this issue Jun 19, 2019 · 0 comments

Comments

Projects
None yet
0 participants
@whitesource-for-github-com
Copy link
Contributor

commented Jun 19, 2019

CVE-2019-8331 - Medium Severity Vulnerability

Vulnerable Library - bootstrap-2.1.0.js

The most popular front-end framework for developing responsive, mobile first projects on the web.

Library home page: https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/2.1.0/bootstrap.js

Path to vulnerable library: /ksa/ksa-web-root/ksa-web/target/ROOT/rs/bootstrap/js/bootstrap.js

Dependency Hierarchy:

  • bootstrap-2.1.0.js (Vulnerable Library)

Found in HEAD commit: 5006aa0ad36fa5906f39e37448973c14e9a49114

Vulnerability Details

In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute.

Publish Date: 2019-02-20

URL: CVE-2019-8331

CVSS 3 Score Details (6.1)

Base Score Metrics:

  • Exploitability Metrics:
    • Attack Vector: Network
    • Attack Complexity: Low
    • Privileges Required: None
    • User Interaction: Required
    • Scope: Changed
  • Impact Metrics:
    • Confidentiality Impact: Low
    • Integrity Impact: Low
    • Availability Impact: None

For more information on CVSS3 Scores, click here.

Suggested Fix

Type: Upgrade version

Origin: twbs/bootstrap#28236

Release Date: 2019-02-20

Fix Resolution: 3.4.1, 4.3.1


Step up your Open Source Security Game with WhiteSource here

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.