Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Add example contact us app in FP sandbox

  • Loading branch information...
commit 3e196a97b20cfe88bf9df2036d01b3169968a813 1 parent cae2be5
@elbaschid elbaschid authored
View
1  docs/source/index.rst
@@ -31,6 +31,7 @@ Contents:
installation
concepts
+ blocks
recipes
contributing
reference
View
0  sandboxes/fancypages/contact_us/__init__.py
No changes.
View
10 sandboxes/fancypages/contact_us/forms.py
@@ -0,0 +1,10 @@
+# -*- coding: utf-8 -*-
+from __future__ import absolute_import, unicode_literals
+from django import forms
+from django.utils.translation import ugettext_lazy as _
+
+
+class ContactUsForm(forms.Form):
+ name = forms.CharField(label=_("Name"))
+ email = forms.EmailField(label=_("Email"))
+ message = forms.CharField(label=_("Message"), widget=forms.Textarea())
View
0  sandboxes/fancypages/contact_us/views.py
No changes.
View
90 tox.ini
@@ -1,40 +1,64 @@
-# Tox (http://tox.testrun.org/) is a tool for running tests
-# in multiple virtualenvs. This configuration file will run the
-# test suite on all supported python versions. To use it, "pip install tox"
-# and then run "tox" from this directory.
-
-[tox]
-envlist = py27-1.5, py27-1.6, py27-1.7, py34-1.5, py34-1.6, py34-1.7
-
[testenv]
-commands = py.test --pep8 {posargs:tests}
-
-[testenv:py27-1.5]
-basepython = python2.7
+skipsdist = True
+usedevelop = True
deps = -r{toxinidir}/requirements_dev.txt
- django==1.5.8
+deps15 =
+ https://github.com/django/django/archive/stable/1.5.x.zip#egg=django
+deps16 =
+ https://github.com/django/django/archive/stable/1.6.x.zip#egg=django
+deps17 =
+ https://github.com/django/django/archive/1.7b4.zip
+fp-migratewithsouth =
+ python {toxinidir}/sandboxes/fancypages/manage.py syncdb --noinput
+fp-migratewithdjango =
+ python {toxinidir}/sandboxes/fancypages/manage.py migrate --noinput
+commands = py.test {posargs:tests}
-[testenv:py34-1.5]
-basepython = python3.4
-deps = -r{toxinidir}/requirements_dev.txt
- django==1.5.8
+[testenv:py27-fp-1.5]
+basepython=python2.7
+deps = {[testenv]deps}
+ {[testenv]deps15}
-[testenv:py27-1.6]
-basepython = python2.7
-deps = -r{toxinidir}/requirements_dev.txt
- django==1.6.5
+[testenv:py27-fp-1.6]
+basepython=python2.7
+deps = {[testenv]deps}
+ {[testenv]deps16}
-[testenv:py34-1.6]
-basepython = python3.4
-deps = -r{toxinidir}/requirements_dev.txt
- django==1.6.5
+[testenv:py27-fp-1.6-postgres]
+basepython=python2.7
+deps = {[testenv]deps}
+ {[testenv]deps16}
+commands = {[testenv]fp-migratewithsouth}
+environment = DJANGO_CONFIGURATION="FancypagesPostgres"
-[testenv:py27-1.7]
-basepython = python2.7
-deps = -r{toxinidir}/requirements_dev.txt
- https://github.com/django/django/archive/1.7b4.zip
+[testenv:py27-fp-1.6-mysql]
+basepython=python2.7
+deps = {[testenv]deps}
+ {[testenv]deps16}
+commands = {[testenv]fp-migratewithsouth}
+environment = DJANGO_CONFIGURATION="FancypagesMysql"
-[testenv:py34-1.7]
-basepython = python3.4
-deps = -r{toxinidir}/requirements_dev.txt
- https://github.com/django/django/archive/1.7b4.zip
+[testenv:py27-fp-1.7]
+basepython=python2.7
+deps = {[testenv]deps}
+ {[testenv]deps17}
+commands = {[testenv]fp-migratewithdjango}
+environment = DJANGO_CONFIGURATION="FancypagesPostgres"
+
+#[testenv:py27-ofp-1.5]
+#basepython=python2.7
+#deps = {[testenv]deps}
+# {[testenv]deps15}
+#commands = {[testenv]ocommands}
+#
+#[testenv:py27-ofp-1.6]
+#basepython=python2.7
+#deps = {[testenv]deps}
+# {[testenv]deps16}
+#commands = {[testenv]ocommands}
+#
+#[testenv:py27-ofp-1.7]
+#basepython=python2.7
+#deps = {[testenv]deps}
+# {[testenv]deps17}
+#commands = {[testenv]ocommands}
Please sign in to comment.
Something went wrong with that request. Please try again.