You can clone with
No one assigned
Oscar 0.4 required django-extra-views>=0.2.4 (but <0.3)
This extension requires version 0.5.2
This conflict causes some pain on install and may prevent automated installation
Why is v0.5.2 required? Is the right solution to change Oscar's dependencies?
Add install target
Doesn't quite work yet due to the django-extra-views conflict of #7. It
should start working once that issue is resolved.
I actually looked at that because I remembered that something had changed in a later version of django-extra-views. The reason I switch to 0.5.2 was that the get_inlines() method was introduced (line 21). However, I just realised that I didn't use it in the end so we could actually switch django-oscar-stores back to 0.2.2 to make it compatible with the current setup of Oscar.
How would you prefer to handle this?
As far as I know, I haven't introduced any backwards incompatible changes between 0.2.4 and 0.5.2. There's no reason why the Oscar requirement can't be changed to be >=0.2.4 and <= 0.5.2
This should be fixed with tangentlabs/django-oscar#407.