Installation of TARDIS: No errors but not successful #90

Closed
WillFox opened this Issue Mar 8, 2014 · 3 comments

Projects

None yet

2 participants

@WillFox

I am still attempting to get Tardis to install. At the moment I run the following:
pip install tardis-sn --user --pre
I then received a rundown of the redundancies, which are all met, and then the following
cleaning up
It does not fail, just acts as if it was testing requirements.

The full readout:
Requirement already satisfied (use --upgrade to upgrade): tardis-sn in /home/username/.local/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): astropy>=0.3 in /usr/local/lib/python2.7/dist-packages (from tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): numpy in /usr/local/lib/python2.7/dist-packages (from tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): scipy in /usr/local/lib/python2.7/dist-packages (from tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): h5py in /usr/lib/python2.7/dist-packages (from tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): pandas>=0.12 in /usr/local/lib/python2.7/dist-packages (from tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): pyyaml in /usr/local/lib/python2.7/dist-packages (from tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): python-dateutil in /usr/local/lib/python2.7/dist-packages (from pandas>=0.12->tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): pytz>=2011k in /usr/local/lib/python2.7/dist-packages (from pandas>=0.12->tardis-sn)
Requirement already satisfied (use --upgrade to upgrade): six in /usr/local/lib/python2.7/dist-packages (from python-dateutil->pandas>=0.12->tardis-sn)
Cleaning up...

@WillFox

Python imports fine and am able to run everything from within python, but tardis cannot be found on the command line. (i.e. tardis: command not found)

SYS INFO:
Ubuntu 12.04
Python 2.7.3
Numpy: 1.8
Scipy:0.13.3
Astropy: 0.3.1
H5py: 2.0.1
Pandas: 0.13.1
Pyyaml: installed (believe 3.0+)

@wkerzendorf
TARDIS SN collaboration member

@WillFox It's not in your path. You probably need to check where --user on your operating system installs to,

@WillFox

This was the exact issue. All tests I have run in the last two days work correctly now. Thank you.
--user installed it outside of my system PATH

@WillFox WillFox closed this Mar 10, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment