Content Security Policy prevents content injection attacks by allowing admins to specify which sites they trust.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
acp
adm/style
config
event
language
migrations
travis
.travis.yml
README.md
composer.json
license.txt
version-check.json

README.md

phpBB 3.1 Content Security Policy

This is an extension for the phpBB forums software. You need an instalation of phpBB 3.1.x to use this.

DESCRIPTION

Adds content securety headers to phpBB

INSTALATION

To install this extension download it from here and upload the files in your forum under /ext/tas2580/contentsecurety. After that go to the Admin panel of your forum and navigate in to Customise -> Extension Management -> Extensions. Search this extension in the list of extensions and click on Enable.

SUPPORT

You can get support for this extension on phpbb.com or in german on phpbb.de. For more informations look at my Website.

Help to translate

If you use the extension in your forum and translated it therefor in your language, it would be nice if you would send me a pull request. Also it may be that existing translations after uptates of the extensions are incomplete. So you can help me if you complete or correct existing language files.

LICENSE

GNU General Public License v2

Build Status