jQuery UI integration in Wicket (1.5.x, 6.x & 7.x)
Clone or download
Pull request Compare This branch is 442 commits behind sebfz1:wicket8.x.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
wicket-jquery-ui-calendar
wicket-jquery-ui-core
wicket-jquery-ui-plugins
wicket-jquery-ui-samples
wicket-jquery-ui-themes
wicket-jquery-ui
wicket-kendo-ui-culture
wicket-kendo-ui-themes
wicket-kendo-ui
.gitignore
LICENSE.md
README.md
RELEASE.md
UPGRADE.md
eclipse-cleanup.xml
eclipse-formatter.xml
pom.xml

README.md

wicket-jquery-ui

jQuery UI integration in Wicket 1.5.x, Wicket 6.x & Wicket7.x
Build Status

Artifacts

  • jQuery UI wicket-jquery-ui
  • Calendar wicket-jquery-ui-calendar
  • Plugins wicket-jquery-ui-plugins
  • Kendo UI wicket-kendo-ui

Getting started

In order to get started using this API, you may download appropriate jar(s) or set a maven dependency.

Download jar(s)

If you are not using maven, you need to download the core jar here: http://central.maven.org/maven2/com/googlecode/wicket-jquery-ui/

You may also download other jars as required (ie: wicket-kendo-ui).
Once done, just include the jar(s) in your project's build path.

Using Maven

<dependency>
    <groupId>com.googlecode.wicket-jquery-ui</groupId>
    <artifactId>wicket-jquery-ui</artifactId>
    <version>7.0.0</version> <!-- or 1.5.11, 6.20.0 -->
</dependency>

If the version you specified is snapshot, you might define this repository:

<repositories>
    <repository>
        <id>sonatype-snapshots</id>
        <name>Sonatype Snapshots Repository</name>
        <url>http://oss.sonatype.org/content/repositories/snapshots/</url>
        <snapshots>
            <enabled>true</enabled>
        </snapshots>
    </repository>
</repositories>

Versions

wicket-jquery-uiWicketjQuery UI
7.0.07.0.01.11.4
7.0.0-M67.0.0-M61.11.4
7.0.0-M57.0.0-M51.11.2
6.20.06.20.01.11.4
6.19.06.19.01.11.2
6.18.06.18.01.11.2
6.17.06.17.01.11.1
6.16.06.16.01.11.0
6.15.06.15.01.10.4
6.14.06.14.01.10.4
6.13.16.13.01.10.4
6.13.06.13.01.10.3
6.12.06.12.01.10.3
6.11.06.11.01.10.3
6.10.06.10.01.10.3
6.9.16.9.01.10.3
6.9.06.9.01.10.3
6.8.16.8.01.10.3
6.7.06.7.01.10.2
1.5.111.5.111.11.0
1.5.101.5.101.10.2
wicket-kendo-uiWicketKendo UI
7.0.07.0.02015.2.624 (ASFv2)
7.0.0-M67.0.0-M62015.1.318 (ASFv2)
7.0.0-M57.0.0-M52014.3.1119 (ASFv2)
6.20.06.20.02015.1.318 (ASFv2)
6.19.06.19.02014.3.1119 (ASFv2)
6.18.06.18.02014.2.716 (ASFv2)
6.17.06.17.02014.2.716 (ASFv2)
6.16.06.16.02014.1.416 (ASFv2)
6.15.06.15.02014.1.416 (ASFv2)
6.14.06.14.02013.3.1119 (GPLv3)
6.13.16.13.02013.3.1119 (GPLv3)
6.13.06.13.02013.3.1119 (GPLv3)
6.12.06.12.02013.1.319 (GPLv3)
6.11.06.11.02013.1.319 (GPLv3)
6.10.06.10.02013.1.319 (GPLv3)
6.9.16.9.02013.1.319 (GPLv3)
6.9.06.9.02013.1.319 (GPLv3)
6.8.16.8.02013.1.319 (GPLv3)
6.7.06.7.02012.3.1114 (GPLv3)
1.5.111.5.112014.1.416 (ASFv2)
1.5.101.5.102012.3.1114 (GPLv3)

Setting up the jQuery UI theme

Using standard themes

To use wicket-jquery-ui with a standard theme, just add the corresponding theme dependency to your webapp pom

<dependency>
	<groupId>com.googlecode.wicket-jquery-ui</groupId>
	<artifactId>wicket-jquery-ui-theme-uilightness</artifactId>
	<version>7.0.0</version>
</dependency>

Using a custom theme

Please follow the instruction on How to change resource references

Setting up the Kendo UI theme

Using standard themes

To use wicket-kendo-ui with a standard theme, just add the corresponding theme dependency to your webapp pom

<dependency>
	<groupId>com.googlecode.wicket-jquery-ui</groupId>
	<artifactId>wicket-kendo-ui-theme-default</artifactId>
	<version>7.0.0</version>
</dependency>

Using a custom theme

Please follow the instruction on How to change resource references

You are now ready to use wicket-jquery-ui!

Look at the samples provided in the demo site to get started with the code...
http://www.7thweb.net/wicket-jquery-ui